This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id:
51077
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
tokuhirom+cpan [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: auto_include_deps would mention the (test|build)_requires version.
Currently, auto_include_deps doesn't mention the $version of test_requires($name, $version). This is problem when user call the test_requires('Test::More' => 0.94). Test::More is built-in to older perl, but recent version is not built-in. http://gist.github.com/225125
Applied in trunk. Will be fixed in 0.95. Thanks. On 2009-11-03 Tue 10:48:10, TOKUHIROM wrote:
Show quoted text
> Currently, auto_include_deps doesn't mention the $version of > test_requires($name, $version). > This is problem when user call the test_requires('Test::More' => > 0.94). > Test::More is built-in to older perl, but recent version is not built- > in. > > http://gist.github.com/225125
Hi. 0.95 is out. If you still have the problem, reopen this. Thanks.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.