Skip Menu |
 

This queue is for tickets about the RRD-Simple CPAN distribution.

Report information
The Basics
Id: 50868
Status: open
Priority: 0/
Queue: RRD-Simple

People
Owner: Nobody in particular
Requestors: MSTEVENS [...] cpan.org
Cc: mstevens [...] etla.org
AdminCc:

Bug Information
Severity: Important
Broken in: 1.44
Fixed in: (no value)



CC: mstevens [...] etla.org
Download (untitled) / with headers
text/plain 2.9k
Fails tests on install: t/10pod.t .......................... 1/2 # Failed test 'blib/lib/RRD/Simple.pm' # at /opt/dianomi/perl/lib/site_perl/5.8.9/Test/Pod.pm line 219. # blib/lib/RRD/Simple.pm (2158): L<text|scheme:...> is invalid according to perlpod # Looks like you failed 1 test of 2. (okay, the rest also fail because I didn't install RRDs yet, but I don't think that one's my fault) [root@server2 ~]# perl -v This is perl, v5.8.9 built for x86_64-linux Copyright 1987-2008, Larry Wall Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit. Complete documentation for Perl, including FAQ lists, should be found on this system using "man perl" or "perldoc perl". If you have access to the Internet, point your browser at http://www.perl.org/, the Perl Home Page. [root@server2 ~]# perl -V Summary of my perl5 (revision 5 version 8 subversion 9) configuration: Platform: osname=linux, osvers=2.6.18-128.7.1.el5, archname=x86_64-linux uname='linux 240738-app1.server2.dianomi.co.uk 2.6.18-128.7.1.el5 #1 smp wed aug 19 04:00:49 edt 2009 x86_64 x86_64 x86_64 gnulinux ' config_args='-des -Dprefix=/opt/dianomi/perl -Accflags=-fPIC' hint=recommended, useposix=true, d_sigaction=define usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef useperlio=define d_sfio=undef uselargefiles=define usesocks=undef use64bitint=define use64bitall=define uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='cc', ccflags ='-fPIC -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64', optimize='-O2', cppflags='-fPIC -fno-strict-aliasing -pipe -I/usr/local/include' ccversion='', gccversion='4.1.2 20080704 (Red Hat 4.1.2-44)', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='cc', ldflags =' -L/usr/local/lib' libpth=/usr/local/lib /lib /usr/lib /lib64 /usr/lib64 /usr/local/lib64 libs=-lnsl -ldb -ldl -lm -lcrypt -lutil -lc perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc libc=/lib/libc-2.5.so, so=so, useshrplib=false, libperl=libperl.a gnulibc_version='2.5' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E' cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib' Characteristics of this binary (from libperl): Compile-time options: PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT USE_FAST_STDIO USE_LARGE_FILES USE_PERLIO Built under linux Compiled at Aug 27 2009 15:45:08 @INC: /opt/dianomi/perl/lib/5.8.9/x86_64-linux /opt/dianomi/perl/lib/5.8.9 /opt/dianomi/perl/lib/site_perl/5.8.9/x86_64-linux /opt/dianomi/perl/lib/site_perl/5.8.9 .
Subject: L<text|scheme:...> is invalid according to perlpod
From: paul [...] city-fan.org
Download (untitled) / with headers
text/plain 517b
On Tue Oct 27 08:48:40 2009, MSTEVENS wrote: Show quoted text
> Fails tests on install: > > t/10pod.t .......................... 1/2 > # Failed test 'blib/lib/RRD/Simple.pm' > # at /opt/dianomi/perl/lib/site_perl/5.8.9/Test/Pod.pm line 219. > # blib/lib/RRD/Simple.pm (2158): L<text|scheme:...> is invalid according > to perlpod > # Looks like you failed 1 test of 2. > > (okay, the rest also fail because I didn't install RRDs yet, but I don't > think that one's my fault)
It's not your fault. Attached patch fixes it for me.
Subject: RRD-Simple-1.44-pod.patch
Fix for https://rt.cpan.org/Public/Bug/Display.html?id=50868 --- RRD-Simple-1.44/lib/RRD/Simple.pm 2008-01-24 18:25:50.000000000 +0000 +++ RRD-Simple-1.44/lib/RRD/Simple.pm 2010-03-03 12:22:21.204308186 +0000 @@ -2153,9 +2153,8 @@ L<http://perlgirl.org.uk> If you like this software, why not show your appreciation by sending the -author something nice from her -L<Amazon wishlist|http://www.amazon.co.uk/gp/registry/1VZXC59ESWYK0?sort=priority>? -( http://www.amazon.co.uk/gp/registry/1VZXC59ESWYK0?sort=priority ) +author something nice from her Amazon wishlist +(L<http://www.amazon.co.uk/gp/registry/1VZXC59ESWYK0?sort=priority>)? =head1 COPYRIGHT
From: paul [...] city-fan.org
Download (untitled) / with headers
text/plain 184b
On Wed Mar 03 07:29:59 2010, paul@city-fan.org wrote: Show quoted text
> It's not your fault. Attached patch fixes it for me.
Actually no patch is needed, just a version of Test::Pod other than 1.40.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.