This queue is for tickets about the XML-LibXSLT CPAN distribution.

Report information
The Basics
Id:
50487
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
MAROS [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
1.70
Fixed in:
(no value)



Subject: Test t/07blankdoc.t blocks
marosmac:XML-LibXSLT-1.70 maros$ make Skip blib/lib/XML/benchmark.pl (unchanged) Skip blib/lib/XML/LibXSLT.pm (unchanged) cc -c -I/opt/local/include -I/opt/local/include/libxml2 -I/opt/local/include -I/opt/local/include/libxml2 -fno-common -DPERL_DARWIN -no-cpp-precomp -arch x86_64 -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -I/opt/local/include -O3 -DVERSION=\"1.70\" -DXS_VERSION=\"1.70\" "-I/opt/perl5.10.1/lib/5.10.1/darwin-thread-multi-2level/CORE" -DHAVE_BLANK -DHAVE_BLANK -DHAVE_EXSLT LibXSLT.c cc -c -I/opt/local/include -I/opt/local/include/libxml2 -I/opt/local/include -I/opt/local/include/libxml2 -fno-common -DPERL_DARWIN -no-cpp-precomp -arch x86_64 -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -I/opt/local/include -O3 -DVERSION=\"1.70\" -DXS_VERSION=\"1.70\" "-I/opt/perl5.10.1/lib/5.10.1/darwin-thread-multi-2level/CORE" -DHAVE_BLANK -DHAVE_BLANK -DHAVE_EXSLT perl-libxml-mm.c Running Mkbootstrap for XML::LibXSLT () chmod 644 LibXSLT.bs rm -f blib/arch/auto/XML/LibXSLT/LibXSLT.bundle LD_RUN_PATH="/opt/local/lib:/usr/lib" env MACOSX_DEPLOYMENT_TARGET=10.3 cc -arch x86_64 -bundle -undefined dynamic_lookup -L/usr/local/lib -L/opt/local/lib -fstack-protector LibXSLT.o perl-libxml-mm.o -o blib/arch/auto/XML/LibXSLT/LibXSLT.bundle \ -L/opt/local/lib -lxslt -lxml2 -lz -lpthread -liconv -lm -L/opt/local/lib -lexslt -lpthread -liconv -lgdbm -ldbm -ldl -lm -lutil -lc \ ld: warning: in /usr/local/lib/libz.dylib, file is not of required architecture chmod 755 blib/arch/auto/XML/LibXSLT/LibXSLT.bundle cp LibXSLT.bs blib/arch/auto/XML/LibXSLT/LibXSLT.bs chmod 644 blib/arch/auto/XML/LibXSLT/LibXSLT.bs Manifying blib/man3/XML::LibXSLT.3 marosmac:XML-LibXSLT-1.70 maros$ make test PERL_DL_NONLAZY=1 /opt/perl5.10/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/01basic.t ...... 1/4 Compiled against: libxslt 10125, libxml2 20704 Running: libxslt 10125, libxml2 20704 Compiled with EXSLT: yes t/01basic.t ...... ok t/02dromeds.t .... ok t/03input.t ...... ok t/04params.t ..... ok t/05quick.t ...... ok t/06entities.t ... ok t/06output.t ..... ok t/07blankdoc.t ... 1/5 <------------- stops here and I have to abort Summary of my perl5 (revision 5 version 10 subversion 1) configuration: Platform: osname=darwin, osvers=10.0.0, archname=darwin-thread-multi-2level uname='darwin marosmac 10.0.0 darwin kernel version 10.0.0: fri jul 31 22:47:34 pdt 2009; root:xnu-1456.1.25~1release_i386 i386 ' config_args='-Duse64bitall -Dprefix=/opt/perl5.10.1 -Duse64bitint -des -Duseithreads' hint=recommended, useposix=true, d_sigaction=define useithreads=define, usemultiplicity=define useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=define, use64bitall=define, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='cc', ccflags ='-fno-common -DPERL_DARWIN -no-cpp-precomp -arch x86_64 -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -I/opt/local/include', optimize='-O3', cppflags='-no-cpp-precomp -arch x86_64 -fno-common -DPERL_DARWIN -no-cpp-precomp -arch x86_64 -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -I/opt/local/include' ccversion='', gccversion='4.2.1 (Apple Inc. build 5646)', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='env MACOSX_DEPLOYMENT_TARGET=10.3 cc -arch x86_64', ldflags =' -arch x86_64 -fstack-protector -L/usr/local/lib -L/opt/local/lib' libpth=/usr/local/lib /opt/local/lib /usr/lib libs=-lgdbm -ldbm -ldl -lm -lutil -lc perllibs=-ldl -lm -lutil -lc libc=/usr/lib/libc.dylib, so=dylib, useshrplib=false, libperl=libperl.a gnulibc_version='' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=bundle, d_dlsymun=undef, ccdlflags=' ' cccdlflags=' ', lddlflags=' -bundle -undefined dynamic_lookup -L/usr/local/lib -L/opt/local/lib -fstack-protector' Characteristics of this binary (from libperl): Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES USE_PERLIO USE_REENTRANT_API Built under darwin Compiled at Sep 24 2009 14:31:51 @INC: /opt/perl5.10.1/lib/5.10.1/darwin-thread-multi-2level /opt/perl5.10.1/lib/5.10.1 /opt/perl5.10.1/lib/site_perl/5.10.1/darwin-thread-multi-2level /opt/perl5.10.1/lib/site_perl/5.10.1 .
Hi, please try with libxslt-1.1.26; version 1.1.25 contains a deadlock that's causing this, see http://mail.gnome.org/archives/xml/2009-September/msg00034.html I guess I'll have to introduce a blacklist in XML::LibXSLT's Makefile.PL. -- Petr On Wed Oct 14 04:53:38 2009, MAROS wrote:
Show quoted text
> marosmac:XML-LibXSLT-1.70 maros$ make > Skip blib/lib/XML/benchmark.pl (unchanged) > Skip blib/lib/XML/LibXSLT.pm (unchanged) > cc -c -I/opt/local/include -I/opt/local/include/libxml2 > -I/opt/local/include -I/opt/local/include/libxml2 -fno-common > -DPERL_DARWIN -no-cpp-precomp -arch x86_64 -fno-strict-aliasing -pipe > -fstack-protector -I/usr/local/include -I/opt/local/include -O3 > -DVERSION=\"1.70\" -DXS_VERSION=\"1.70\" > "-I/opt/perl5.10.1/lib/5.10.1/darwin-thread-multi-2level/CORE" > -DHAVE_BLANK -DHAVE_BLANK -DHAVE_EXSLT LibXSLT.c > cc -c -I/opt/local/include -I/opt/local/include/libxml2 > -I/opt/local/include -I/opt/local/include/libxml2 -fno-common > -DPERL_DARWIN -no-cpp-precomp -arch x86_64 -fno-strict-aliasing -pipe > -fstack-protector -I/usr/local/include -I/opt/local/include -O3 > -DVERSION=\"1.70\" -DXS_VERSION=\"1.70\" > "-I/opt/perl5.10.1/lib/5.10.1/darwin-thread-multi-2level/CORE" > -DHAVE_BLANK -DHAVE_BLANK -DHAVE_EXSLT perl-libxml-mm.c > Running Mkbootstrap for XML::LibXSLT () > chmod 644 LibXSLT.bs > rm -f blib/arch/auto/XML/LibXSLT/LibXSLT.bundle > LD_RUN_PATH="/opt/local/lib:/usr/lib" env MACOSX_DEPLOYMENT_TARGET=10.3 > cc -arch x86_64 -bundle -undefined dynamic_lookup -L/usr/local/lib > -L/opt/local/lib -fstack-protector LibXSLT.o perl-libxml-mm.o -o > blib/arch/auto/XML/LibXSLT/LibXSLT.bundle \ > -L/opt/local/lib -lxslt -lxml2 -lz -lpthread -liconv -lm > -L/opt/local/lib -lexslt -lpthread -liconv -lgdbm -ldbm -ldl -lm -lutil > -lc \ > > ld: warning: in /usr/local/lib/libz.dylib, file is not of required > architecture > chmod 755 blib/arch/auto/XML/LibXSLT/LibXSLT.bundle > cp LibXSLT.bs blib/arch/auto/XML/LibXSLT/LibXSLT.bs > chmod 644 blib/arch/auto/XML/LibXSLT/LibXSLT.bs > Manifying blib/man3/XML::LibXSLT.3 > marosmac:XML-LibXSLT-1.70 maros$ make test > PERL_DL_NONLAZY=1 /opt/perl5.10/bin/perl "-MExtUtils::Command::MM" "-e" > "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t > t/01basic.t ...... 1/4 > > Compiled against: libxslt 10125, libxml2 20704 > Running: libxslt 10125, libxml2 20704 > Compiled with EXSLT: yes > > t/01basic.t ...... ok > t/02dromeds.t .... ok > t/03input.t ...... ok > t/04params.t ..... ok > t/05quick.t ...... ok > t/06entities.t ... ok > t/06output.t ..... ok > t/07blankdoc.t ... 1/5 > > <------------- stops here and I have to abort > > > Summary of my perl5 (revision 5 version 10 subversion 1) configuration: > > Platform: > osname=darwin, osvers=10.0.0, archname=darwin-thread-multi-2level > uname='darwin marosmac 10.0.0 darwin kernel version 10.0.0: fri jul > 31 22:47:34 pdt 2009; root:xnu-1456.1.25~1release_i386 i386 ' > config_args='-Duse64bitall -Dprefix=/opt/perl5.10.1 -Duse64bitint > -des -Duseithreads' > hint=recommended, useposix=true, d_sigaction=define > useithreads=define, usemultiplicity=define > useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef > use64bitint=define, use64bitall=define, uselongdouble=undef > usemymalloc=n, bincompat5005=undef > Compiler: > cc='cc', ccflags ='-fno-common -DPERL_DARWIN -no-cpp-precomp -arch > x86_64 -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include > -I/opt/local/include', > optimize='-O3', > cppflags='-no-cpp-precomp -arch x86_64 -fno-common -DPERL_DARWIN > -no-cpp-precomp -arch x86_64 -fno-strict-aliasing -pipe > -fstack-protector -I/usr/local/include -I/opt/local/include' > ccversion='', gccversion='4.2.1 (Apple Inc. build 5646)', > gccosandvers='' > intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 > d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 > ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', > lseeksize=8 > alignbytes=8, prototype=define > Linker and Libraries: > ld='env MACOSX_DEPLOYMENT_TARGET=10.3 cc -arch x86_64', ldflags =' > -arch x86_64 -fstack-protector -L/usr/local/lib -L/opt/local/lib' > libpth=/usr/local/lib /opt/local/lib /usr/lib > libs=-lgdbm -ldbm -ldl -lm -lutil -lc > perllibs=-ldl -lm -lutil -lc > libc=/usr/lib/libc.dylib, so=dylib, useshrplib=false,
libperl=libperl.a
Show quoted text
> gnulibc_version='' > Dynamic Linking: > dlsrc=dl_dlopen.xs, dlext=bundle, d_dlsymun=undef, ccdlflags=' ' > cccdlflags=' ', lddlflags=' -bundle -undefined dynamic_lookup > -L/usr/local/lib -L/opt/local/lib -fstack-protector' > > > Characteristics of this binary (from libperl): > Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV > PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP > USE_64_BIT_ALL > USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES > USE_PERLIO USE_REENTRANT_API > Built under darwin > Compiled at Sep 24 2009 14:31:51 > @INC: > /opt/perl5.10.1/lib/5.10.1/darwin-thread-multi-2level > /opt/perl5.10.1/lib/5.10.1 > /opt/perl5.10.1/lib/site_perl/5.10.1/darwin-thread-multi-2level > /opt/perl5.10.1/lib/site_perl/5.10.1 > .
Add a blacklist for this libxslt version in the repository. It will be included in XML-LibXSLT-1.71.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.