This queue is for tickets about the ExtUtils-Install CPAN distribution.

Report information
The Basics
Id:
50315
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
kendrick.killian [...] colostate.edu
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: ExtUtils::Packlist::FH1" used only once error
Date: Wed, 7 Oct 2009 19:01:55 -0600
To: bug-ExtUtils-Install@rt.cpan.org
From: Kendrick Killian <Kendrick.Killian@colostate.edu>
I am getting the following two perl errors: Name "ExtUtils::Packlist::FH1" used only once: possible typo at / System/Library/Perl/5.10.0/ExtUtils/Packlist.pm line 25. Name "ExtUtils::Packlist::FH2" used only once: possible typo at / System/Library/Perl/5.10.0/ExtUtils/Packlist.pm line 25. system MacBook Pro MAC OS X 10.6.1 Standard upgrade of a 10.5.8 (upgraded from 10.5 by normal Apple channels) No upgrades or additional modules uname -a Darwin icegrass 10.0.0 Darwin Kernel Version 10.0.0: Fri Jul 31 22:47:34 PDT 2009; root:xnu-1456.1.25~1/RELEASE_I386 i386 Perl Version perl -V Summary of my perl5 (revision 5 version 10 subversion 0) configuration: Platform: osname=darwin, osvers=10.0, archname=darwin-thread-multi-2level uname='darwin neige.apple.com 10.0 darwin kernel version 10.0.0d8: tue may 5 19:29:59 pdt 2009; root:xnu-1437.2~2release_i386 i386 ' config_args='-ds -e -Dprefix=/usr -Dccflags=-g -pipe -Dldflags= -Dman3ext=3pm -Duseithreads -Duseshrplib -Dinc_version_list=none - Dcc=gcc-4.2' hint=recommended, useposix=true, d_sigaction=define useithreads=define, usemultiplicity=define useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef use64bitint=define, use64bitall=define, uselongdouble=undef usemymalloc=n, bincompat5005=undef Compiler: cc='gcc-4.2', ccflags ='-arch x86_64 -arch i386 -arch ppc -g - pipe -fno-common -DPERL_DARWIN -fno-strict-aliasing -I/usr/local/ include', optimize='-Os', cppflags='-g -pipe -fno-common -DPERL_DARWIN -fno-strict-aliasing -I/usr/local/include' ccversion='', gccversion='4.2.1 (Apple Inc. build 5646)', gccosandvers='' intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678 d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16 ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8 alignbytes=8, prototype=define Linker and Libraries: ld='gcc-4.2 -mmacosx-version-min=10.6', ldflags ='-arch x86_64 - arch i386 -arch ppc -L/usr/local/lib' libpth=/usr/local/lib /usr/lib libs=-ldbm -ldl -lm -lutil -lc perllibs=-ldl -lm -lutil -lc libc=/usr/lib/libc.dylib, so=dylib, useshrplib=true, libperl=libperl.dylib gnulibc_version='' Dynamic Linking: dlsrc=dl_dlopen.xs, dlext=bundle, d_dlsymun=undef, ccdlflags=' ' cccdlflags=' ', lddlflags='-arch x86_64 -arch i386 -arch ppc - bundle -undefined dynamic_lookup -L/usr/local/lib' Characteristics of this binary (from libperl): Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES USE_PERLIO USE_REENTRANT_API Locally applied patches: /Library/Perl/Updates/<version> comes before system perl directories installprivlib and installarchlib points to the Updates directory Built under darwin Compiled at Jun 24 2009 00:35:27 @INC: /Library/Perl/Updates/5.10.0 /System/Library/Perl/5.10.0/darwin-thread-multi-2level /System/Library/Perl/5.10.0 /Library/Perl/5.10.0/darwin-thread-multi-2level /Library/Perl/5.10.0 /Network/Library/Perl/5.10.0/darwin-thread-multi-2level /Network/Library/Perl/5.10.0 /Network/Library/Perl /System/Library/Perl/Extras/5.10.0/darwin-thread-multi-2level /System/Library/Perl/Extras/5.10.0 . Simplest command that reproduces error. Place the package Rterm.pm, 10 lines reproduced below, in a file. Issue the command perl -we 'use Rterm;' File Rterm.pm =========================================== #!/usr/local/bin/perl -w # {package Rterm; use strict; use ExtUtils::Installed; my $instmod = ExtUtils::Installed->new(); } 1; __END__ ===========================================
I can confirm this also happens on my system. I see this error while running CPANPLUS: Name "ExtUtils::Packlist::FH1" used only once: possible typo at /usr/share/perl/5.10/ExtUtils/Packlist.pm line 25. My ExtUtils::Packlist is v1.43 and perl is 5.10.0 Hope this helps! :) -- ~Apocalypse
This was fixed in bleadperl with commit a91616b6b. The fix was then tweaked in commit 7d6220ecd.
Subject: Re: [rt.cpan.org #50315] ExtUtils::Packlist::FH1" used only once error
Date: Sat, 14 Jan 2012 12:04:18 -0800
To: bug-ExtUtils-Install@rt.cpan.org
From: Michael G Schwern <schwern@pobox.com>
On 2012.1.14 1:08 AM, Father Chrysostomos via RT wrote:
Show quoted text
> This was fixed in bleadperl with commit a91616b6b. The fix was then > tweaked in commit 7d6220ecd.
BTW ExtUtils::Install has had 5.6.0 as the minimum since 2008 (release 1.46). warnings.pm is safe to use.
On Sat Jan 14 15:04:31 2012, schwern@pobox.com wrote:
Show quoted text
> On 2012.1.14 1:08 AM, Father Chrysostomos via RT wrote:
> > This was fixed in bleadperl with commit a91616b6b. The fix was then > > tweaked in commit 7d6220ecd.
> > BTW ExtUtils::Install has had 5.6.0 as the minimum since 2008 (release > 1.46). > warnings.pm is safe to use.
Well, I saw this: package ExtUtils::Packlist; use 5.00503; And I’ve already made the change now, so let’s leave it as it is. :-)
I realized we can just use Symbol now, so I replaced all that crufted custom filehandle generation code with it. https://github.com/schwern/ExtUtils-Install/commit/c95435d4fc5e4c25a305cdf83a9403431df85688 I'll give Yves a chance to respond before cutting a release.
1.62 was released to CPAN which incorporates these changes. Many thanks.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.