Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Net-SSH2 CPAN distribution.

Report information
The Basics
Id:
50292
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
HMBRAND [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Critical
Broken in:
(no value)
Fixed in:
(no value)



Subject: Fail on recent libssh2 (0.18)
README requires libssh2 0.11 or up: --8<--- DEPENDENCIES This module requires these other modules and libraries: libSSH2 (http://www.libssh2.org; tested with 0.11 and 0.12) OpenSSL (http://www.openssl.org) zlib (optional; http://www.zlib.net) -->8--- It still fails though for 0.18: --8<--- .cpan/build/Net-SSH2-0.27-hJpjst 116 > make test PERL_DL_NONLAZY=1 /pro/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t t/Net-SSH2.t .. 1/73 # Failed test 'use Net::SSH2;' # at t/Net-SSH2.t line 19. # Tried to use 'Net::SSH2'. # Error: Can't load 'blib/arch/auto/Net/SSH2/SSH2.so' for module Net::SSH2: blib/arch/auto/Net/SSH2/SSH2.so: undefined symbol: libssh2_channel_request_pty_size_ex at /pro/lib/perl5/5.10.1/x86_64- linux/DynaLoader.pm line 200. # at (eval 4) line 2 # Compilation failed in require at (eval 4) line 2. # BEGIN failed--compilation aborted at (eval 4) line 2. &Net::SSH2::constant not defined at t/Net-SSH2.t line 22 # Looks like you planned 73 tests but ran 1. # Looks like you failed 1 test of 1 run. # Looks like your test exited with 255 just after 1. t/Net-SSH2.t .. Dubious, test returned 255 (wstat 65280, 0xff00) Failed 73/73 subtests Test Summary Report ------------------- t/Net-SSH2.t (Wstat: 65280 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 255 Parse errors: Bad plan. You planned 73 tests but ran 1. Files=1, Tests=1, 0 wallclock secs ( 0.02 usr 0.00 sys + 0.03 cusr 0.00 csys = 0.05 CPU) Result: FAIL Failed 1/1 test programs. 1/1 subtests failed. make: *** [test_dynamic] Error 255 .cpan/build/Net-SSH2-0.27-hJpjst 119 > zypper se ssh2 Loading repository data... Reading installed packages... S | Name | Summary | Type --+---------------+------------------------------------------ +----------- | libssh2 | A library implementing the SSH2 protocol | srcpackage i | libssh2-1 | A library implementing the SSH2 protocol | package i | libssh2-devel | Include files for libssh2 | package .cpan/build/Net-SSH2-0.27-hJpjst 120 > rpm -qa | grep ssh2 libssh2-devel-0.18-0 libssh2-1-0.18-0 .cpan/build/Net-SSH2-0.27-hJpjst 121 > nm /usr/lib64/libssh2.so.1 | grep channel_request 0000000000006bb0 T libssh2_channel_request_pty_ex .cpan/build/Net-SSH2-0.27-hJpjst 122 >
Subject: Re: [rt.cpan.org #50292] Fail on recent libssh2 (0.18)
Date: Wed, 7 Oct 2009 20:56:40 -0400
To: "H.Merijn Brand via RT" <bug-Net-SSH2@rt.cpan.org>
From: Rafael Kitover <rkitover@io.com>
On Wed, Oct 07, 2009 at 08:35:25AM -0400, H.Merijn Brand via RT wrote: ...
Show quoted text
> # Error: Can't load 'blib/arch/auto/Net/SSH2/SSH2.so' for module > Net::SSH2: blib/arch/auto/Net/SSH2/SSH2.so: undefined symbol: > libssh2_channel_request_pty_size_ex at /pro/lib/perl5/5.10.1/x86_64- > linux/DynaLoader.pm line 200.
... Interesting, I think it's the recent pty patch I added, will retest with 0.18 tonight.
Fixed in 0.28. -- Rafael


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.