Skip Menu |
 

This queue is for tickets about the Devel-Declare CPAN distribution.

Report information
The Basics
Id: 49926
Status: resolved
Priority: 0/
Queue: Devel-Declare

People
Owner: Nobody in particular
Requestors: awwaiid [...] thelackthereof.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Dependencies
Download (untitled) / with headers
text/plain 172b
Just tried to install Devel::Declare against a blank perl 5.10.1 install, and had to manually install ExtUtils::Depends and B::Hooks::OP::Check. Then it worked :) --Brock
CC: undisclosed-recipients:;
Subject: Re: [rt.cpan.org #49926] Dependencies
Date: Tue, 22 Sep 2009 17:31:38 -0500
To: bug-MooseX-Declare [...] rt.cpan.org
From: Jonathan Rockway <jon [...] jrock.us>
Download (untitled) / with headers
text/plain 908b
* On Tue, Sep 22 2009, Brock Wilcox via RT wrote: Show quoted text
> Tue Sep 22 18:17:31 2009: Request 49926 was acted upon. > Transaction: Ticket created by AWWAIID > Queue: MooseX-Declare > Subject: Dependencies > Broken in: (no value) > Severity: (no value) > Owner: Nobody > Requestors: awwaiid@thelackthereof.org > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=49926 > > > > Just tried to install Devel::Declare against a blank perl 5.10.1 > install, and had to manually install ExtUtils::Depends and > B::Hooks::OP::Check. Then it worked :)
These are declared in the Makefile.PL, so I think this is a cpan or Module::Install bug. (The META.yml mentions B::Hooks::OP::Check in "requires", but not ExtUtils::Depends. It does mention them both in configure_requires, however.) Regards, Jonathan Rockway -- print just => another => perl => hacker => if $,=$"


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.