Skip Menu |
 

This queue is for tickets about the CGI-Simple CPAN distribution.

Report information
The Basics
Id: 49830
Status: rejected
Priority: 0/
Queue: CGI-Simple

People
Owner: Nobody in particular
Requestors: rmb32 [...] cornell.edu
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in: 1.112
Fixed in: (no value)



Subject: fails building under Shipwright, possibly in other (strange?) environments
Builds fine in a regular environment, using M::B 0.340201 But, building a vessel that includes CGI::Simple under Shipwright, CGI::Simple fails with the following output: ============= bin/shipwright-builder --install-base=$PWD/../sgn_build --skip-test --skip-man-pages --verbose --only cpan-IO-Scalar,cpan-CGI-Simple Building cpan-CGI-Simple WARNING: Can't find resource file '' defined in environment. No options loaded Checking whether your kit is complete... Looks good Checking prerequisites... - ERROR: IO::Scalar is not installed ERRORS/WARNINGS FOUND IN PREREQUISITES. You may wish to install the versions of the modules indicated above before proceeding with this installation Deleting Build Removed previous script 'Build' Creating new 'Build' script for 'CGI-Simple' version '1.112' Can't locate object method "find_perl_interpreter" via package "Module::Build" at Build line 49. build cpan-CGI-Simple make part failed. at bin/shipwright-builder line 548 main::_install('cpan-CGI-Simple', 'GLOB(0x8428138)') called at bin/shipwright-builder line 403 main::install() called at bin/shipwright-builder line 266 ============ But, if I add the following, it builds OK. --- inc/MyBuilder.pm (revision 1107) +++ inc/MyBuilder.pm (working copy) @@ -1,5 +1,6 @@ package MyBuilder; +use Module::Build; use base qw( Module::Build ); sub create_build_script { Now, I completely don't understand why this helps. But it causes CGI::Simple to build correctly under Shipwright, where it didn't before.
Download (untitled) / with headers
text/plain 108b
I've been unable so far to formulate a small test case that can reproduce this. Decreasing its importance.
Download (untitled) / with headers
text/plain 624b
Aha. Here's a small reproducible test case. With a bash-like shell: #!/bin/sh SHIPWRIGHT_REPOSITORY=fs:/tmp/foo; cd; rm -rf /tmp/foo; shipwright create; shipwright import cpan:CGI::Simple; cd /tmp/foo; rm -rf dists; rm -rf /tmp/vessel_*; bin/shipwright-builder --skip-test --skip-man-pages Upon poking into it further, I think it's some kind of interaction between Shipwright's method of patching Module::Build to turn off manpage generations and tests (Shipwright::Util::PatchModuleBuild), and the 'use base' in CGI::Simple's inc/MyBuilder.pm. I'm gonna close this ticket, I think this is more of a Shipwright problem.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.