Skip Menu |
 

This queue is for tickets about the ExtUtils-Install CPAN distribution.

Report information
The Basics
Id: 49637
Status: open
Priority: 0/
Queue: ExtUtils-Install

People
Owner: Nobody in particular
Requestors: cpan [...] otoh.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.54
Fixed in: (no value)



Subject: version() doesn't work for Bundles
Download (untitled) / with headers
text/plain 558b
version() doesn't work for Bundles like IO::Compress. e.g. perl -e 'use ExtUtils::Installed; my $mod="IO::Compress"; my $inst = ExtUtils::Installed->new($mod); my $ver = $inst->version($mod) || die "$!"; print "$ver\n"' This will die with No such file or directory at -e line 1. As it's looking for IO/Compress.pm but can't find it (as the bundle doesn't install it). It should do something smarter to get the bundle version rather than just dying. -- Save our economy, demand finishing metric conversion from your federal and state representatives.
Download (untitled) / with headers
text/plain 1007b
On Fri Sep 11 20:35:11 2009, psa wrote: Show quoted text
> version() doesn't work for Bundles like IO::Compress. > > e.g. > > perl -e 'use ExtUtils::Installed; my $mod="IO::Compress"; my $inst = > ExtUtils::Installed->new($mod); my $ver = $inst->version($mod) || die > "$!"; print "$ver\n"' > > This will die with > No such file or directory at -e line 1. > > As it's looking for IO/Compress.pm but can't find it (as the bundle > doesn't install it). > > It should do something smarter to get the bundle version rather than > just dying.
Confirmed that this is still a problem: ##### $ perl -MExtUtils::Installed -E 'say ExtUtils::Installed->new(skip_cwd => 1)->version(q{List::Compare});' 0.39 $ perl -MExtUtils::Installed -E 'say ExtUtils::Installed->new(skip_cwd => 1)->version(q{IO::Compress});' IO::Compress is not installed at -e line 1. $ perl -MExtUtils::Installed -E 'say ExtUtils::Installed->new(skip_cwd => 1)->version(q{ExtUtils::Installed});' ExtUtils::Installed is not installed at -e line 1. #####


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.