Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Web-Scraper CPAN distribution.

Report information
The Basics
Id: 49516
Status: open
Priority: 0/
Queue: Web-Scraper

People
Owner: Nobody in particular
Requestors: MTHURN [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.31
Fixed in: (no value)

Attachments


Subject: error in prerequisites regarding LibXML?
Download (untitled) / with headers
text/plain 1.2k
When installing via CPANPLUS, the Makefile.PL says that HTML::TreeBuilder::LibXML is optional, BUT when I choose not to install it, the tests fail. Also, is there a reason you need the LibXML version? Why can't you use plain old HTML::TreeBuilder? (LibXML is not easily available on Windows, so I think you are cutting out a large user base.) [LibXML] - HTML::TreeBuilder::LibXML ...missing. (would need 0.04) ==> Auto-install the 1 optional module(s) from CPAN? [y] n ... t/xml-simple.t .......... Can't locate HTML/TreeBuilder/LibXML.pm in @INC (@INC contains: C:\src\.cpanplus\5.10.0\build\Web-Scraper-0.31\inc C:\src\.cpanplus\5.10.0\build\Web-Scraper-0.31\blib\lib C:\src\.cpanplus\5.10.0\build\Web-Scraper-0.31\blib\arch C:\src\.cpanplus\5.10.0\build\Web-Scraper-0.31\blib\lib C:\src\.cpanplus\5.10.0\build\Web-Scraper-0.31\blib\arch C:/Perl/site/lib C:/Perl/lib .) at C:\src\.cpanplus\5.10.0\build\Web-Scraper-0.31\blib\lib/Web/Scraper/LibXML.pm line 5. BEGIN failed--compilation aborted at C:\src\.cpanplus\5.10.0\build\Web-Scraper-0.31\blib\lib/Web/Scraper/LibXML.pm line 5. Compilation failed in require at t/xml-simple.t line 3. BEGIN failed--compilation aborted at t/xml-simple.t line 3. t/xml-simple.t .......... Dubious, test returned 2 (wstat 512, 0x200) -- - - Martin 'Kingpin' Thurn
Download (untitled) / with headers
text/plain 378b
On 2009-9月-08 火 09:18:37, MTHURN wrote: Show quoted text
> When installing via CPANPLUS, the Makefile.PL says that > HTML::TreeBuilder::LibXML is optional, BUT when I choose not to > install > it, the tests fail.
Here is a patch for Web-Scraper *0.32* to avoid this problem. -- ignoring all tests in t/xml-simple.t when Web::Scraper::LibXML is invalid by lack of HTML::TreeBuilder::LibXML.
Subject: Web-Scraper-0.32_no_libxml.patch
=== modified file 't/xml-simple.t' --- t/xml-simple.t 2010-04-14 03:21:21 +0000 +++ t/xml-simple.t 2010-04-14 03:22:08 +0000 @@ -1,11 +1,16 @@ use strict; use Test::Base; -use Web::Scraper::LibXML; +eval "use Web::Scraper::LibXML;"; +my $wont_test = $@; filters { expected => [ 'lines', 'chomp' ] }; plan tests => 1 * blocks; run { + if ( $wont_test ) { + ok 1; + return; + } my $block = shift; my $s = scraper { process $block->selector, "value[]", $block->get;


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.