This queue is for tickets about the Catalyst-Plugin-Authentication CPAN distribution.

Report information
The Basics
Id:
49086
Status:
resolved
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
bo [...] startsiden.no
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
(no value)
Fixed in:
(no value)



Subject: Missing dependency
Hi, From what I gather you are missing the Class::Data::Inheritable as a dependency. Can you please add it to your Makefile.PL if this is correct? regards, Bjørn-Olav
I think that this was a broken Catalyst::Runtime I had.
Heh... In Catalyst::Runtime: test_requires 'Class::Data::Inheritable'; From the tests: t/04_authentication.............. # Failed test 'use Catalyst::Plugin::Authentication;' # in t/04_authentication.t at line 7. # Tried to use 'Catalyst::Plugin::Authentication'. # Error: Base class package "Class::Data::Inheritable" is empty. # (Perhaps you need to 'use' the module which defines that package first.) # at /build/Catalyst-Plugin-Authentication-0.10014/blib/lib/Catalyst/Plugin/Authentication.pm line 3 # BEGIN failed--compilation aborted at t/04_authentication.t line 7. # Compilation failed in require at (eval 3) line 2. # BEGIN failed--compilation aborted at (eval 3) line 2.
Class::Data::Inheritable is actually not needed by Catalyst::Plugin::Authentication, ergo I have removed it along with other cleanups in the latest release. Cheers t0m


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.