This queue is for tickets about the Class-DBI CPAN distribution.

Report information
The Basics
Id:
48875
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
RURBAN [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Critical
Broken in:
(no value)
Fixed in:
(no value)



Subject: bare qv disallowed
perl-5.10.1 with version 0.77 requires the following patch for Class- DBI-3.0.17 --- Class-DBI-v3.0.17/lib/Class/DBI.pm.orig 2007-10-04 23:27:07.000000000 +0200 +++ Class-DBI-v3.0.17/lib/Class/DBI.pm 2009-08-20 12:31:17.953125000 +0200 @@ -7,7 +7,7 @@ package Class::DBI; -use version; $VERSION = qv('3.0.17'); +use version; $VERSION = version::qv('3.0.17'); use strict; use warnings; -- Reini Urban
Subject: Re: [rt.cpan.org #48875] bare qv disallowed
Date: Thu, 20 Aug 2009 11:23:20 -0700
To: bug-Class-DBI@rt.cpan.org
From: Michael G Schwern <schwern@pobox.com>
Reini Urban via RT wrote:
Show quoted text
> perl-5.10.1 with version 0.77 requires the following patch for Class- > DBI-3.0.17
Neither version 0.77 nor 0.7701 run with 5.10.0 has such restriction. The documentation doesn't mention it. It looks like a 5.10.1 bug to me, it would break a huge pile of code. I don't have a copy to check.
Show quoted text
> --- Class-DBI-v3.0.17/lib/Class/DBI.pm.orig 2007-10-04 > 23:27:07.000000000 +0200 > +++ Class-DBI-v3.0.17/lib/Class/DBI.pm 2009-08-20 12:31:17.953125000 > +0200 > @@ -7,7 +7,7 @@ > > package Class::DBI; > > -use version; $VERSION = qv('3.0.17'); > +use version; $VERSION = version::qv('3.0.17'); > > use strict; > use warnings; >
-- If at first you don't succeed--you fail. -- "Portal" demo


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.