Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CGI CPAN distribution.

Report information
The Basics
Id: 48856
Status: resolved
Priority: 0/
Queue: CGI

People
Owner: MARKSTOS [...] cpan.org
Requestors: MARKSTOS [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: (no value)



Subject: Fix compatibility with 5.8.0 and earlier: avoid utf8::is_utf8()
Download (untitled) / with headers
text/plain 284b
The introduction of utf8::is_utf8() broke compatibility with Perl 5.8.0 and earlier. You can see the test failure here: http://www.nntp.perl.org/group/perl.cpan.testers/2009/08/msg5033628.html Maybe Encode::is_utf8() can be used instead? Supporting back to Perl 5.6 would be nice.
Download (untitled) / with headers
text/plain 545b
I have a proposed fix for this in the tree now. The fix just makes escape() be UTF-unaware below 5.8.1 instead of 5.7. This may make tests pass for those versions. Perhaps there's a better fix that that uses Encode::is_utf8() or something else, but I'll let something who is actually using 5.8.0 or earlier figure out what the better patch is. It's my understanding that UTF-8 support made a big improvement around Perl 5.8.2, so people who care about it alot should probably find a way to upgrade instead of further patching CGI.pm Mark
Released in 3.48


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.