Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CGI CPAN distribution.

Report information
The Basics
Id: 48811
Status: resolved
Priority: 0/
Queue: CGI

People
Owner: Nobody in particular
Requestors: ansgar [...] 43-1.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Please do not ship ancient versions of Test::More, Test::Simple
Date: Tue, 18 Aug 2009 19:48:17 +0200
To: bug-CGI.pm [...] rt.cpan.org
From: Ansgar Burchardt <ansgar [...] 43-1.org>
Download (untitled) / with headers
text/plain 361b
Hi, CGI.pm includes an ancient version (0.18, from 2001) of Test::More and Test::Simple in t/lib/Test. As not all tests even include a use lib "t/lib" line, these modules are only used for some tests, the other tests use the far more recent version of Test::More included in the Perl distribution. Please consider removing t/lib/Test/*. Regards, Ansgar
Download (untitled) / with headers
text/plain 135b
I agree this is a good idea. We'll take care of this soon, and try to standardize our "use lib" lines in the test suite in the process.
Thanks, a patch for this is in my github repo now.
Subject: Thanks, released
Download (untitled) / with headers
text/plain 160b
The patch for this ticket has now been released in CGI.pm 3.47, and this ticket is considered resolved. Thanks again for you help to improve CGI.pm! Mark


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.