Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Test-WWW-Mechanize CPAN distribution.

Report information
The Basics
Id: 48619
Status: resolved
Priority: 0/
Queue: Test-WWW-Mechanize

People
Owner: Nobody in particular
Requestors: david [...] davidfavor.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Test::WWW::Mechanize + pel-5.10.1-RC1-12 fails test
Date: Tue, 11 Aug 2009 07:37:20 -0500
To: bug-Test-WWW-Mechanize [...] rt.cpan.org
From: David Favor <david [...] davidfavor.com>
Download (untitled) / with headers
text/plain 3.1k
PERL_DL_NONLAZY=1 /runtime/perl-5.10.1-RC1-12/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t # Testing Test::WWW::Mechanize 1.24, with WWW::Mechanize 1.58, LWP 5.830, Perl 5.010001, /runtime/perl-5.10.1-RC1-12/bin/perl t/00load.t .............. ok t/autolint.t ............ ok t/back_ok.t ............. ok t/click_ok.t ............ ok t/content_contains.t .... ok t/content_lacks.t ....... ok t/follow_link_ok.t ...... ok t/followable_links.t .... ok t/get_ok-parms.t ........ ok t/get_ok.t .............. ok t/has_tag.t ............. ok t/head_ok-parms.t ....... ok t/head_ok.t ............. ok t/html_lint_ok.t ........ ok t/link_content.t ........ ok t/link_status.t ......... ok t/links_ok.t ............ ok t/new.t ................. ok t/page_links_content.t .. ok t/page_links_ok.t ....... ok t/pod-coverage.t ........ ok t/pod.t ................. ok # Failed test 'sanity check: we can load goodlinks.html' # at t/put_ok.t line 34. Use of uninitialized value $v in substitution (s///) at /runtime/perl-5.10.1-RC1-12/lib/site_perl/5.10.1/LWP/Protocol/http.pm line 159, <DATA> line 16. Use of uninitialized value $v in concatenation (.) or string at /runtime/perl-5.10.1-RC1-12/lib/site_perl/5.10.1/Net/HTTP/Methods.pm line 154, <DATA> line 16. # Failed test 'PUTs existing URI and reports success' # at t/put_ok.t line 38. # STDOUT is: # not ok 1 - Try to PUT goodlinks.html # # not: # ok 1 - Try to PUT goodlinks.html # # as expected # STDERR is: # # Failed test 'Try to PUT goodlinks.html' # # at t/put_ok.t line 37. # # 500 # # read timeout # # not: # # as expected # Failed test 'And the result should be true' # at t/put_ok.t line 40. Use of uninitialized value $v in substitution (s///) at /runtime/perl-5.10.1-RC1-12/lib/site_perl/5.10.1/LWP/Protocol/http.pm line 159, <DATA> line 16. Use of uninitialized value $v in concatenation (.) or string at /runtime/perl-5.10.1-RC1-12/lib/site_perl/5.10.1/Net/HTTP/Methods.pm line 154, <DATA> line 16. # Failed test 'PUTs existing URI and reports success - default desc' # at t/put_ok.t line 45. # STDOUT is: # not ok 1 - PUT http://localhost:13432/goodlinks.html # # not: # ok 1 - PUT http://localhost:13432/goodlinks.html # # as expected # STDERR is: # # Failed test 'PUT http://localhost:13432/goodlinks.html' # # at t/put_ok.t line 44. # # 500 # # read timeout # # not: # # as expected t/put_ok.t .............. Failed 4/11 subtests t/stuff_inputs.t ........ ok t/submit_form_ok.t ...... ok -- Love feeling your best ever, all day, every day? Click http://RadicalHealth.com/join for the easy way.
Having the same problem trying to install on Mac OS X 10.5.8 using stock Perl. Install Log ------------------- Running install for module 'Test::WWW::Mechanize' Running make for P/PE/PETDANCE/Test-WWW-Mechanize-1.24.tar.gz CPAN: checksum security checks disabled because Digest::SHA not installed. Test-WWW-Mechanize-1.24/ Test-WWW-Mechanize-1.24/Changes Test-WWW-Mechanize-1.24/Makefile.PL Test-WWW-Mechanize-1.24/MANIFEST Test-WWW-Mechanize-1.24/Mechanize.pm Test-WWW-Mechanize-1.24/META.yml Test-WWW-Mechanize-1.24/README Test-WWW-Mechanize-1.24/t/ Test-WWW-Mechanize-1.24/t/00load.t Test-WWW-Mechanize-1.24/t/autolint.t Test-WWW-Mechanize-1.24/t/back_ok.t Test-WWW-Mechanize-1.24/t/click_ok.t Test-WWW-Mechanize-1.24/t/content_contains.t Test-WWW-Mechanize-1.24/t/content_lacks.t Test-WWW-Mechanize-1.24/t/follow_link_ok.t Test-WWW-Mechanize-1.24/t/followable_links.t Test-WWW-Mechanize-1.24/t/get_ok-parms.t Test-WWW-Mechanize-1.24/t/get_ok.t Test-WWW-Mechanize-1.24/t/has_tag.t Test-WWW-Mechanize-1.24/t/head_ok-parms.t Test-WWW-Mechanize-1.24/t/head_ok.t Test-WWW-Mechanize-1.24/t/html/ Test-WWW-Mechanize-1.24/t/html/bad.html Test-WWW-Mechanize-1.24/t/html/badlinks.html Test-WWW-Mechanize-1.24/t/html/form.html Test-WWW-Mechanize-1.24/t/html/good.html Test-WWW-Mechanize-1.24/t/html/goodlinks.html Test-WWW-Mechanize-1.24/t/html/manylinks.html Test-WWW-Mechanize-1.24/t/html_lint_ok.t Test-WWW-Mechanize-1.24/t/link_content.t Test-WWW-Mechanize-1.24/t/link_status.t Test-WWW-Mechanize-1.24/t/links_ok.t Test-WWW-Mechanize-1.24/t/new.t Test-WWW-Mechanize-1.24/t/page_links_content.t Test-WWW-Mechanize-1.24/t/page_links_ok.t Test-WWW-Mechanize-1.24/t/pod-coverage.t Test-WWW-Mechanize-1.24/t/pod.t Test-WWW-Mechanize-1.24/t/put_ok.t Test-WWW-Mechanize-1.24/t/stuff_inputs.html Test-WWW-Mechanize-1.24/t/stuff_inputs.t Test-WWW-Mechanize-1.24/t/submit_form_ok.t Test-WWW-Mechanize-1.24/t/TestServer.pm CPAN.pm: Going to build P/PE/PETDANCE/Test-WWW-Mechanize-1.24.tar.gz Checking if your kit is complete... Looks good Writing Makefile for Test::WWW::Mechanize cp Mechanize.pm blib/lib/Test/WWW/Mechanize.pm Manifying blib/man3/Test::WWW::Mechanize.3pm PETDANCE/Test-WWW-Mechanize-1.24.tar.gz /usr/bin/make -j2 -j2 -- OK Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00load.t .............. t/00load.t .............. 1/1 # Testing Test::WWW::Mechanize 1.24, with WWW::Mechanize 1.60, LWP 5.831, Perl 5.008008, /usr/bin/perl t/00load.t .............. ok t/autolint.t ............ t/autolint.t ............ skipped: HTML::Lint is not installed, cannot test autolint t/back_ok.t ............. t/back_ok.t ............. 1/11 t/back_ok.t ............. 2/11 t/back_ok.t ............. ok t/click_ok.t ............ t/click_ok.t ............ 1/? t/click_ok.t ............ 2/? t/click_ok.t ............ ok t/content_contains.t .... t/content_contains.t .... 1/5 t/content_contains.t .... 2/5 t/content_contains.t .... ok t/content_lacks.t ....... t/content_lacks.t ....... 1/5 t/content_lacks.t ....... 2/5 t/content_lacks.t ....... ok t/follow_link_ok.t ...... t/follow_link_ok.t ...... 1/5 t/follow_link_ok.t ...... 2/5 t/follow_link_ok.t ...... ok t/followable_links.t .... t/followable_links.t .... 1/3 t/followable_links.t .... 2/3 t/followable_links.t .... ok t/get_ok-parms.t ........ t/get_ok-parms.t ........ 1/16 t/get_ok-parms.t ........ ok t/get_ok.t .............. t/get_ok.t .............. 1/11 t/get_ok.t .............. 2/11 t/get_ok.t .............. ok t/has_tag.t ............. t/has_tag.t ............. 1/7 t/has_tag.t ............. 2/7 t/has_tag.t ............. ok t/head_ok-parms.t ....... t/head_ok-parms.t ....... 1/16 t/head_ok-parms.t ....... ok t/head_ok.t ............. t/head_ok.t ............. 1/11 t/head_ok.t ............. 2/11 t/head_ok.t ............. ok t/html_lint_ok.t ........ t/html_lint_ok.t ........ skipped: HTML::Lint is not installed, cannot test html_lint_ok t/link_content.t ........ t/link_content.t ........ 1/11 t/link_content.t ........ 2/11 t/link_content.t ........ ok t/link_status.t ......... t/link_status.t ......... 1/8 t/link_status.t ......... 2/8 t/link_status.t ......... ok t/links_ok.t ............ t/links_ok.t ............ 1/7 t/links_ok.t ............ 2/7 t/links_ok.t ............ 6/7 t/links_ok.t ............ ok t/new.t ................. t/new.t ................. 1/7 t/new.t ................. ok t/page_links_content.t .. t/page_links_content.t .. 1/9 t/page_links_content.t .. 2/9 t/page_links_content.t .. ok t/page_links_ok.t ....... t/page_links_ok.t ....... 1/5 t/page_links_ok.t ....... 2/5 t/page_links_ok.t ....... ok t/pod-coverage.t ........ t/pod-coverage.t ........ skipped: Test::Pod::Coverage 0.08 required for testing POD coverage t/pod.t ................. t/pod.t ................. 1/1 t/pod.t ................. ok t/put_ok.t .............. t/put_ok.t .............. 1/11 t/put_ok.t .............. 2/11 t/put_ok.t .............. 3/11 # Failed test 'sanity check: we can load goodlinks.html' # at t/put_ok.t line 34. Use of uninitialized value in substitution (s///) at /Users/trish/local/lib/perl5/site_perl/LWP/Protocol/http.pm line 159, <DATA> line 16. Use of uninitialized value in concatenation (.) or string at /Users/trish/local/lib/perl5/site_perl/Net/HTTP/Methods.pm line 154, <DATA> line 16. t/put_ok.t .............. 4/11 # Failed test 'PUTs existing URI and reports success' # at t/put_ok.t line 38. # STDOUT is: # not ok 1 - Try to PUT goodlinks.html # # not: # ok 1 - Try to PUT goodlinks.html # # as expected # STDERR is: # # Failed test 'Try to PUT goodlinks.html' # # at t/put_ok.t line 37. # # 500 # # read timeout # # not: # # as expected # Failed test 'And the result should be true' # at t/put_ok.t line 40. Use of uninitialized value in substitution (s///) at /Users/trish/local/lib/perl5/site_perl/LWP/Protocol/http.pm line 159, <DATA> line 16. Use of uninitialized value in concatenation (.) or string at /Users/trish/local/lib/perl5/site_perl/Net/HTTP/Methods.pm line 154, <DATA> line 16. t/put_ok.t .............. 7/11 # Failed test 'PUTs existing URI and reports success - default desc' # at t/put_ok.t line 45. # STDOUT is: # not ok 1 - PUT http://localhost:13432/goodlinks.html # # not: # ok 1 - PUT http://localhost:13432/goodlinks.html # # as expected # STDERR is: # # Failed test 'PUT http://localhost:13432/goodlinks.html' # # at t/put_ok.t line 44. # # 500 # # read timeout # # not: # # as expected t/put_ok.t .............. Failed 4/11 subtests t/stuff_inputs.t ........ t/stuff_inputs.t ........ 1/44 t/stuff_inputs.t ........ ok t/submit_form_ok.t ...... t/submit_form_ok.t ...... 1/? t/submit_form_ok.t ...... 2/? t/submit_form_ok.t ...... ok Test Summary Report ------------------- t/put_ok.t (Wstat: 0 Tests: 11 Failed: 4) Failed tests: 3-4, 6-7 Files=25, Tests=200, 563 wallclock secs ( 0.14 usr 0.08 sys + 4.68 cusr 1.07 csys = 5.97 CPU) Result: FAIL Failed 1/25 test programs. 4/200 subtests failed. make: *** [test_dynamic] Error 255 PETDANCE/Test-WWW-Mechanize-1.24.tar.gz /usr/bin/make test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports PETDANCE/Test-WWW-Mechanize-1.24.tar.gz Running make install make test had returned bad status, won't install without force
Download (untitled) / with headers
text/plain 160b
Exactly the same issue on 5.10.1 - Win32/strawberry perl Interesting is that on 5.10.0 - Win32/strawberry all tests PASS (with some warnings but pass). -- kmx
Fixed in 1.28. Please don't use the RT queue for bugs. Use the code.google.com queue.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.