Skip Menu |
 

This queue is for tickets about the Unicode-LineBreak CPAN distribution.

Report information
The Basics
Id: 48585
Status: resolved
Priority: 0/
Queue: Unicode-LineBreak

People
Owner: hatuka [...] nezumi.nu
Requestors: julien.jourdan [...] cru.fr
Cc: olivier.salaun [...] cru.fr
AdminCc:

Bug Information
Severity: Important
Broken in: 1.002.510
Fixed in: (no value)



CC: olivier.salaun [...] cru.fr
Subject: Problème d'installation. Make test
Download (untitled) / with headers
text/plain 280b
Installation automatique par CPAN impossible. installation manuelle : make test : erreurs nombreuses make install : pas d'installation. Copié-collé du terminal dans error_unicode-linebreak.txt -- Assistant ingénieur au CRU (Comité Réseau des Universités) Développeur Sympa
Subject: error_unicode-linebreak.txt

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 376b
Julien, Vous devez installer la module Test::More. Si vous avez échoué à la compilation de nouveau, le signaler. On 月曜日 8月 10 09:31:07 2009, julien wrote: Show quoted text
> Installation automatique par CPAN impossible. > installation manuelle : > make test : erreurs nombreuses > make install : pas d'installation. > > Copié-collé du terminal dans error_unicode-linebreak.txt
CC: julien.jourdan [...] cru.fr, Sympa Authors <sympa-authors [...] cru.fr>
Subject: Re: [rt.cpan.org #48585] Problème d'installation. Make test
Date: Tue, 11 Aug 2009 09:38:33 +0200
To: bug-Unicode-LineBreak [...] rt.cpan.org
From: Olivier Salaün <olivier.salaun [...] cru.fr>
Download (untitled) / with headers
text/plain 824b
Hello Soji, Thanks for your quick answer. On our Red Hat Server 5.3 (with 5.8.8) Test::More was not provided. We first tried to install Unicode-LineBreak through the cpan command line, but it did not try to install Test::More. Shouldn't there be a dependency between Unicode-LineBreak and Test::More? Hatuka*nezumi - IKEDA Soji via RT a écrit : Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=48585 > > > Julien, > > Vous devez installer la module Test::More. Si vous avez échoué à la > compilation de nouveau, le signaler. > > On 月曜日 8月 10 09:31:07 2009, julien wrote: >
>> Installation automatique par CPAN impossible. >> installation manuelle : >> make test : erreurs nombreuses >> make install : pas d'installation. >> >> Copié-collé du terminal dans error_unicode-linebreak.txt >>
> >
Download (untitled) / with headers
text/plain 1.2k
Test::More is required during ``make test'' phase only. It is not dependent during ``make install'' phase or binary distributions (e.g. with binary RPM). I suppose this report is not specific to Unicode-LineBreak (along with ``Permission non accordée'' error on ``make install''). On 火曜日 8月 11 03:37:45 2009, olivier.salaun@cru.fr wrote: Show quoted text
> Hello Soji, > > Thanks for your quick answer. > > On our Red Hat Server 5.3 (with 5.8.8) Test::More was not provided. > We first tried to install Unicode-LineBreak through the cpan command > line, but it did not try to install Test::More. > Shouldn't there be a dependency between Unicode-LineBreak and Test::More? > > > Hatuka*nezumi - IKEDA Soji via RT a écrit :
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=48585 > > > > > Julien, > > > > Vous devez installer la module Test::More. Si vous avez échoué à la > > compilation de nouveau, le signaler. > > > > On 月曜日 8月 10 09:31:07 2009, julien wrote: > >
> >> Installation automatique par CPAN impossible. > >> installation manuelle : > >> make test : erreurs nombreuses > >> make install : pas d'installation. > >> > >> Copié-collé du terminal dans error_unicode-linebreak.txt > >>
> > > >
>
CC: julien.jourdan [...] cru.fr, Sympa Authors <sympa-authors [...] cru.fr>
Subject: Re: [rt.cpan.org #48585] Problème d'installation. Make test
Date: Tue, 11 Aug 2009 15:58:15 +0200
To: bug-Unicode-LineBreak [...] rt.cpan.org
From: Olivier Salaün <olivier.salaun [...] cru.fr>
Download (untitled) / with headers
text/plain 1.4k
Should we define Test::More as required module for Sympa software then? Is Test::More used by many CPAN packagers? Hatuka*nezumi - IKEDA Soji via RT a écrit : Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=48585 > > > Test::More is required during ``make test'' phase only. It is not > dependent during ``make install'' phase or binary distributions > (e.g. with binary RPM). > > I suppose this report is not specific to Unicode-LineBreak (along > with ``Permission non accordée'' error on ``make install''). > > On 火曜日 8月 11 03:37:45 2009, olivier.salaun@cru.fr wrote: >
>> Hello Soji, >> >> Thanks for your quick answer. >> >> On our Red Hat Server 5.3 (with 5.8.8) Test::More was not provided. >> We first tried to install Unicode-LineBreak through the cpan command >> line, but it did not try to install Test::More. >> Shouldn't there be a dependency between Unicode-LineBreak and Test::More? >> >> >> Hatuka*nezumi - IKEDA Soji via RT a écrit : >>
>>> <URL: https://rt.cpan.org/Ticket/Display.html?id=48585 > >>> >>> Julien, >>> >>> Vous devez installer la module Test::More. Si vous avez échoué à la >>> compilation de nouveau, le signaler. >>> >>> On 月曜日 8月 10 09:31:07 2009, julien wrote: >>> >>>
>>>> Installation automatique par CPAN impossible. >>>> installation manuelle : >>>> make test : erreurs nombreuses >>>> make install : pas d'installation. >>>> >>>> Copié-collé du terminal dans error_unicode-linebreak.txt >>>> >>>>
>>> >>>
> > > >
Download (untitled) / with headers
text/plain 1.9k
Julien and Olivier, Test::More (Test-Simple) seems to be bundled into Perl at least as of 5.8.0 --- although earlier versions had not tested with Unicode-LineBreak module. I don't know either it is used by ``many'' packagers or not (CPANTS dependency site is down now...). On 火曜日 8月 11 09:57:26 2009, olivier.salaun@cru.fr wrote: Show quoted text
> Should we define Test::More as required module for Sympa software then? > Is Test::More used by many CPAN packagers? > > Hatuka*nezumi - IKEDA Soji via RT a écrit :
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=48585 > > > > > Test::More is required during ``make test'' phase only. It is not > > dependent during ``make install'' phase or binary distributions > > (e.g. with binary RPM). > > > > I suppose this report is not specific to Unicode-LineBreak (along > > with ``Permission non accordée'' error on ``make install''). > > > > On 火曜日 8月 11 03:37:45 2009, olivier.salaun@cru.fr wrote: > >
> >> Hello Soji, > >> > >> Thanks for your quick answer. > >> > >> On our Red Hat Server 5.3 (with 5.8.8) Test::More was not provided. > >> We first tried to install Unicode-LineBreak through the cpan command > >> line, but it did not try to install Test::More. > >> Shouldn't there be a dependency between Unicode-LineBreak and
Test::More? Show quoted text
> >> > >> > >> Hatuka*nezumi - IKEDA Soji via RT a écrit : > >>
> >>> <URL: https://rt.cpan.org/Ticket/Display.html?id=48585 > > >>> > >>> Julien, > >>> > >>> Vous devez installer la module Test::More. Si vous avez échoué à la > >>> compilation de nouveau, le signaler. > >>> > >>> On 月曜日 8月 10 09:31:07 2009, julien wrote: > >>> > >>>
> >>>> Installation automatique par CPAN impossible. > >>>> installation manuelle : > >>>> make test : erreurs nombreuses > >>>> make install : pas d'installation. > >>>> > >>>> Copié-collé du terminal dans error_unicode-linebreak.txt > >>>> > >>>>
> >>> > >>>
> > > > > > > >
>
CC: julien.jourdan [...] cru.fr, Sympa Authors <sympa-authors [...] cru.fr>
Subject: Re: [rt.cpan.org #48585] Problème d'installation. Make test
Date: Mon, 17 Aug 2009 13:58:06 +0200
To: bug-Unicode-LineBreak [...] rt.cpan.org
From: Olivier Salaün <olivier.salaun [...] cru.fr>
Download (untitled) / with headers
text/plain 2.5k
Thank you for the feedback. Actually we have corrected a few things (especially CPAN inactivity timeout) in Sympa CPAN installer, so installation of Test::More should work fine now. Ideally we'd like to distribute a bundle of CPAN package with Sympa to ease the installation process, but it would bring some additional issues such as the burden of maintaining the bundle + RPM/DEB conflicts... Hatuka*nezumi - IKEDA Soji via RT a écrit : Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=48585 > > > Julien and Olivier, > > Test::More (Test-Simple) seems to be bundled into Perl at least as of > 5.8.0 --- although earlier versions had not tested with > Unicode-LineBreak module. > > I don't know either it is used by ``many'' packagers or not (CPANTS > dependency site is down now...). > > On 火曜日 8月 11 09:57:26 2009, olivier.salaun@cru.fr wrote: >
>> Should we define Test::More as required module for Sympa software then? >> Is Test::More used by many CPAN packagers? >> >> Hatuka*nezumi - IKEDA Soji via RT a écrit : >>
>>> <URL: https://rt.cpan.org/Ticket/Display.html?id=48585 > >>> >>> Test::More is required during ``make test'' phase only. It is not >>> dependent during ``make install'' phase or binary distributions >>> (e.g. with binary RPM). >>> >>> I suppose this report is not specific to Unicode-LineBreak (along >>> with ``Permission non accordée'' error on ``make install''). >>> >>> On 火曜日 8月 11 03:37:45 2009, olivier.salaun@cru.fr wrote: >>> >>>
>>>> Hello Soji, >>>> >>>> Thanks for your quick answer. >>>> >>>> On our Red Hat Server 5.3 (with 5.8.8) Test::More was not provided. >>>> We first tried to install Unicode-LineBreak through the cpan command >>>> line, but it did not try to install Test::More. >>>> Shouldn't there be a dependency between Unicode-LineBreak and >>>>
> Test::More? >
>>>> Hatuka*nezumi - IKEDA Soji via RT a écrit : >>>> >>>>
>>>>> <URL: https://rt.cpan.org/Ticket/Display.html?id=48585 > >>>>> >>>>> Julien, >>>>> >>>>> Vous devez installer la module Test::More. Si vous avez échoué à la >>>>> compilation de nouveau, le signaler. >>>>> >>>>> On 月曜日 8月 10 09:31:07 2009, julien wrote: >>>>> >>>>> >>>>>
>>>>>> Installation automatique par CPAN impossible. >>>>>> installation manuelle : >>>>>> make test : erreurs nombreuses >>>>>> make install : pas d'installation. >>>>>> >>>>>> Copié-collé du terminal dans error_unicode-linebreak.txt >>>>>> >>>>>> >>>>>>
>>>>> >>>>> >>>>>
>>> >>> >>>
> > > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.