Skip Menu |
 

This queue is for tickets about the Bryar CPAN distribution.

Report information
The Basics
Id: 48465
Status: resolved
Priority: 0/
Queue: Bryar

People
Owner: md [...] linux.it
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 3.1
Fixed in: (no value)



Subject: Missing "use base Exporter" causes failures under 5.10.x
Download (untitled) / with headers
text/plain 264b
If you look at http://matrix.cpantesters.org/?dist=Bryar&maxver= then you see that Bryar fails on all perl 5.10.x installations. I think this can be fixed by adding a "use base qw(Exporter)" line to the dummy Apache::Constants implementation. Regards, Slaven
Hopefully the new maintainer will pick this up.
Download (untitled) / with headers
text/plain 262b
I do not use Apache so I do not have an easy way to investigate this issue. Can you provide a patch? The failure appears to be: Error: Bareword "OK" not allowed while "strict subs" in use at /USR3/src/blog/Bryar-3.1/blib/lib/Bryar/Frontend/Mod_perl.pm line 30.
Fixed in Bryar 3.2, to be uploaded soon.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.