Skip Menu |
 

This queue is for tickets about the Perl-Dist-Strawberry CPAN distribution.

Report information
The Basics
Id: 48384
Status: resolved
Priority: 0/
Queue: Perl-Dist-Strawberry

People
Owner: Nobody in particular
Requestors: kmx [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: Strawberry 5.8.9 Jul09 - bugy ExtUtils::ParseXS (quite serious)
Hi, I have revealed the problem with ExtUtils::ParseXS 2.20 in Jul09 release. The bug is already reported and solved here: http://rt.cpan.org/Public/Bug/Display.html?id=48104 The problem is that in strawberry 5.8.9 Jul09 you have upgraded ExtUtils::ParseXS from 2.19 to 2.20. With version 2.20 I am for example not able to install Win32::Process and some other modules (I am not talking about failing tests; I am not even able to compile XS part of this module). Workaround is either downgrade to ExtUtils::ParseXS 2.19 or upgrade to latest dev release 2.20_03. The upgrade is however a little bit tricky for inexperienced user as you have to patch ParseXS installed in c:\strawberry\perl\lib not in c:\strawberry\perl\site (which makes it slightly complicated). I think it would be nice at least to warn strawberry 5.8.9/Jul09 users because this issue makes it impossible to install many modules with XS part from cpan. I personally would recommend staying with 5.8.9/Apr09. This issue is not relevant to 5.10.0. I am sorry not to report this issue before release date. -- kmx
Download (untitled) / with headers
text/plain 1.4k
On Mon Aug 03 03:05:58 2009, KMX wrote: Show quoted text
> Hi, > > I have revealed the problem with ExtUtils::ParseXS 2.20 in Jul09 release. > > The bug is already reported and solved here: > http://rt.cpan.org/Public/Bug/Display.html?id=48104 > > The problem is that in strawberry 5.8.9 Jul09 you have upgraded > ExtUtils::ParseXS from 2.19 to 2.20. > > With version 2.20 I am for example not able to install Win32::Process > and some other modules (I am not talking about failing tests; I am not > even able to compile XS part of this module). > > Workaround is either downgrade to ExtUtils::ParseXS 2.19 or upgrade to > latest dev release 2.20_03. The upgrade is however a little bit tricky > for inexperienced user as you have to patch ParseXS installed in > c:\strawberry\perl\lib not in c:\strawberry\perl\site (which makes it > slightly complicated). > > I think it would be nice at least to warn strawberry 5.8.9/Jul09 users > because this issue makes it impossible to install many modules with XS > part from cpan. I personally would recommend staying with 5.8.9/Apr09. > This issue is not relevant to 5.10.0. > > I am sorry not to report this issue before release date. > > -- > kmx
(Trying to clean out the queue) The problem is both release-noted (although the release notes aren't easily findable with 5.8.9.2/5.10.0.6, I'm changing that in the next versions) and directions to fix this are in my blog. Since we're heading toward 5.8.9.3/5.10.1.0 atm, do you think anything else needs done before I close this? --Curtis
Subject: Re: [rt.cpan.org #48384] Strawberry 5.8.9 Jul09 - bugy ExtUtils::ParseXS (quite serious)
Date: Mon, 07 Sep 2009 07:53:36 +0200
To: bug-Perl-Dist-Strawberry [...] rt.cpan.org
From: kmx <kmx [...] volny.cz>
Download (untitled) / with headers
text/plain 592b
Show quoted text
> The problem is both release-noted (although the release notes aren't > easily findable with 5.8.9.2/5.10.0.6, I'm changing that in the next > versions) and directions to fix this are in my blog. > > Since we're heading toward 5.8.9.3/5.10.1.0 atm, do you think anything > else needs done before I close this? >
I am just wondering where to publish a download link to: http://strawberryperl.com/download/strawberry-perl-5.8.9.2-1.msi on www.strawberryperl.com frontpage? or on http://strawberryperl.com/releases.html ? or on your blog http://csjewell.dreamwidth.org/2950.html ? -- kmx
Resolving since October release happened.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.