Skip Menu |
 

This queue is for tickets about the CPANPLUS-Dist-Deb CPAN distribution.

Report information
The Basics
Id: 48381
Status: new
Priority: 0/
Queue: CPANPLUS-Dist-Deb

People
Owner: Nobody in particular
Requestors: thehead [...] patshead.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.12
Fixed in: (no value)



Subject: Problem with dependency versions (cpan vs debian)
Download (untitled) / with headers
text/plain 801b
I was just testing cpan2dist. I was building packages to set up an apt repository for Moose and KiokuDB. Quite a few of the packages that were generated depend on cpan-libpathtools-perl. The version of pathtools that got installed was 3.30-1. All the packages that depended on cpan-libpathtools-perl were requiring a minimum version of cpan-libpathtools-perl 3.2501. Apt believed that 3.2501-1 was newer than 3.30-1. For my testing purposes I cheated and I changed the version of libpathtools to a number greater than 3.2501. After doing that I was able to index the repository and use apt to install all the packages. I imagine this bug is just caused by a discrepancy between the way CPAN and apt compare version numbers. My test virtual machine is running Ubuntu 9.04 with perl 5.10.0.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.