Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 48362
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors: craigberry [...] mac.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: 0.34_03



CC: David Golden <xdaveg [...] gmail.com>
Subject: [PATCH] in new debug test, sometimes Build is Build.com (or Build.bat?)
Date: Fri, 31 Jul 2009 22:20:37 -0500
To: via RT <bug-Module-Build [...] rt.cpan.org>
From: "Craig A. Berry" <craigberry [...] mac.com>
Download (untitled) / with headers
text/plain 668b
debug.t runs Build.PL and then attempts to run Build. On VMS it's always Build.com, not Build. It might be Build.bat on Windows, but I can't remember for sure. The attached patch fixes up the test for VMS (not sure if an additional tweak is needed for Windows). When you've got a Module::Build object instantiated, the name of the generated script should be available under $self->{properties}{build_script}, but it doesn't look like we have that in this test. Show quoted text
________________________________________ Craig A. Berry mailto:craigberry@mac.com "... getting out of a sonnet is much more difficult than getting in." Brad Leithauser

Message body is not shown because sender requested not to inline it.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.