Skip Menu |
 

This queue is for tickets about the Regexp-Grammars CPAN distribution.

Report information
The Basics
Id: 48169
Status: open
Priority: 0/
Queue: Regexp-Grammars

People
Owner: Nobody in particular
Requestors: mschwern [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in: 1.001004
Fixed in: (no value)

Attachments
0001-Declare-the-version-of-perl-required.patch



Subject: Declare the version of perl required
Download (untitled) / with headers
text/plain 101b
This patch declares the required version of Perl in the Build.PL so it can fail early and gracefully.
Subject: 0001-Declare-the-version-of-perl-required.patch
From 9f1ae83281985dfb21ca6eff8374fe8565dc77a1 Mon Sep 17 00:00:00 2001 From: Michael G. Schwern <schwern@pobox.com> Date: Fri, 24 Jul 2009 12:00:19 -0700 Subject: [PATCH] Declare the version of perl required --- Build.PL | 1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/Build.PL b/Build.PL index 614cce7..d9f7f98 100644 --- a/Build.PL +++ b/Build.PL @@ -10,6 +10,7 @@ my $builder = Module::Build->new( requires => { 'Test::More' => 0, 'version' => 0, + perl => '5.10.0', }, add_to_cleanup => [ 'Regexp-Grammars-*' ], ); -- 1.6.2.4
Subject: Re: [rt.cpan.org #48169] Declare the version of perl required
Date: Sat, 25 Jul 2009 18:31:31 -0700
To: bug-Regexp-Grammars [...] rt.cpan.org
From: Damian Conway <damian [...] conway.org>
Applied. Thanks! Damian


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.