Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Time-HiRes CPAN distribution.

Report information
The Basics
Id:
4811
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
adam.arakelian [...] verizon.net
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
1.54
Fixed in:
(no value)



Subject: Slash missing in path
Environment: solaris9 32bit, solaris bundled perl package v5.6.1, with perlgcc, bash shell. In the capture below notice the "/sun4-solaris-64intConfig.pm" - the slash is missing between 64int and Config.pm sparky# /usr/perl5/5.6.1/bin/perlgcc Makefile.PL Configuring Time::HiRes... Using hints hints/solaris.pl... Extra libraries: -lrt... Looking for gettimeofday()... found. Looking for setitimer()... found. Looking for getitimer()... found. You have interval timers (both setitimer and setitimer). Looking for ualarm()... found. Looking for usleep()... found. Looking for nanosleep()... found. You can mix subsecond sleeps with signals. Checking if your kit is complete... Looks good Processing hints file hints/solaris.pl WARNING: Setting ABSTRACT via file 'HiRes.pm' failed Writing Makefile for Time::HiRes Now you may issue 'make'. Do not forget also 'make test'. sparky# make make: *** No rule to make target `/usr/perl5/5.6.1/lib/sun4-solaris-64intConfig.pm', needed by `Makefile'. Stop. sparky#
I suspect something is wrong with your Perl installation(s) because the Sun-supplied Perl 5.6.1 should be looking for the Config.pm in the directory /usr/perl5/site_perl/5.6.1/Solaris/PerlGcc.
On Mar. 13 Gen. 2004 12:08:23, JHI wrote:
Show quoted text
> I suspect something is wrong with your Perl installation(s) because > the Sun-supplied Perl > 5.6.1 should be looking for the Config.pm in the directory > /usr/perl5/site_perl/5.6.1/Solaris/PerlGcc.
Please notice: bash-2.05# find . -name MakeMaker.pm ./5.6.1/lib/ExtUtils/MakeMaker.pm ./site_perl/5.6.1/Solaris/PerlGcc/ExtUtils/MakeMaker.pm ./5.00503/ExtUtils/MakeMaker.pm I have replaced the old MakeMaker.pm of Solaris-PerlGcc with the latest MakeMaker.pm I guess everybody should install the latest ExtUtils::MakeMaker before installing Solaris-PerlGcc-1.3 but overwriting the oldest MakeMaker.pm did work for me
Closing as resolved.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.