This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
48040
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
IKEGAMI [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
1.9402
Fixed in:
(no value)



Subject: A couple of small, easy to fix bugs
I was confronted with:
Show quoted text
---------- BEGIN ---------- t/13tarzip.............Use of uninitialized value in sprintf at C:\progs\perl5100\cpan\build\CPAN-1.9402-jt9Gcc\blib\lib/CPAN/Tarzip.pm line 251. # Looks like your test exited with 9 before it could output anything. t/13tarzip.............dubious Test returned status 9 (wstat 2304, 0x900) DIED. FAILED test 1 Failed 1/1 tests, 0.00% okay ---------- END ---------- The warning and the problem can be fixed with the following changes: ---------- BEGIN patch to CPAN/Tarzip.pm ---------- if ($CPAN::META->has_usable("Archive::Tar")) { - $foundAT = sprintf "'%s'", "Archive::Tar::"->VERSION; + $foundAT = sprintf "'%s'", "Archive::Tar"->VERSION; ---------- END patch to CPAN/Tarzip.pm ---------- ---------- BEGIN patch to CPAN/Tarzip.pm ---------- if ($CPAN::META->has_inst("Compress::Zlib")) { - $foundCZ = sprintf "'%s'", "Compress::Zlib::"->VERSION; + $foundCZ = sprintf "'%s'", "Compress::Zlib"->VERSION; ---------- END patch to CPAN/Tarzip.pm ---------- ---------- BEGIN patch to CPAN.pm ---------- 'Archive::Tar' => [ sub {require Archive::Tar; - unless (CPAN::Version->vge(Archive::Tar::->VERSION, 1.50)) { + unless (CPAN::Version->vge(Archive::Tar::->VERSION, 1.00)) { for ("Will not use Archive::Tar, need 1.00\n") { $CPAN::Frontend->mywarn($_); die $_; } } unless (CPAN::Version->vge(Archive::Tar::->VERSION, 1.50)) { my $atv = Archive::Tar->VERSION; $CPAN::Frontend->mywarn("You have Archive::Tar $atv, but 1.50 or later is recommended. Please upgrade.\n"); } }, ], ---------- END patch to CPAN.pm ----------
Bah, RT wrapped the text. Attaching the patches as files
'Archive::Tar' => [ sub {require Archive::Tar; - unless (CPAN::Version->vge(Archive::Tar::->VERSION, 1.50)) { + unless (CPAN::Version->vge(Archive::Tar::->VERSION, 1.00)) { for ("Will not use Archive::Tar, need 1.00\n") { $CPAN::Frontend->mywarn($_); die $_; } } unless (CPAN::Version->vge(Archive::Tar::->VERSION, 1.50)) { my $atv = Archive::Tar->VERSION; $CPAN::Frontend->mywarn("You have Archive::Tar $atv, but 1.50 or later is recommended. Please upgrade.\n"); } }, ],
if ($CPAN::META->has_inst("Compress::Zlib")) { - $foundCZ = sprintf "'%s'", "Compress::Zlib::"->VERSION; + $foundCZ = sprintf "'%s'", "Compress::Zlib"->VERSION;
if ($CPAN::META->has_usable("Archive::Tar")) { - $foundAT = sprintf "'%s'", "Archive::Tar::"->VERSION; + $foundAT = sprintf "'%s'", "Archive::Tar"->VERSION;
Subject: Re: [rt.cpan.org #48040] A couple of small, easy to fix bugs
Date: Tue, 21 Jul 2009 04:11:44 +0200
To: bug-CPAN@rt.cpan.org
From: andreas.koenig.7os6VVqR@franz.ak.mind.de (Andreas J. Koenig)
Please patch against the repository, code has moved forward already to deal with this bug. % grep repo META.yml repository: git://github.com/andk/cpanpm.git Thanks! -- andreas
On Mon Jul 20 22:12:13 2009, andreas.koenig.7os6VVqR@franz.ak.mind.de wrote:
Show quoted text
> Please patch against the repository, code has moved forward already to > deal with this bug.
The patch to CPAN.pm is moot. The patches to CPAN/Tarzip.pm are still needed.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.