This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
47934
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
ANDK [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
1.9402
Fixed in:
2.16



Subject: == in a version requirement not supported
Reading the source of CPAN::Distribution::_fulfills_all_version_rqs shows that '==' is not supported. Seems to be an oversight. Test distribution could be ELLIOTJS/Perl-Critic-1.099_002.tar.gz which demands 'PPI' => '== 1.203' which tehn gets ignored by CPAN.pm
More recent case that illustrates that it is still not fixed. DMAKI/HTML-HeadParser-Liberal-0.03.tar.gz has a requirement: 'requires' => { 'HTML::HeadParser' => '== 3.69', 'perl' => '5.008005', 'B::Deparse' => '0' }, And it *really* only works with this version of HTML::HeadParser at the moment.
Fixed in commit 20cdb1f.
Fixed with release 2.16. Thanks!


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.