Skip Menu |
 

This queue is for tickets about the IO-Zlib CPAN distribution.

Report information
The Basics
Id: 47793
Status: open
Priority: 0/
Queue: IO-Zlib

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.09
Fixed in: (no value)



Subject: Dependency on Compress::Zlib by version reveals that you need >= 2.009
Download (untitled) / with headers
text/plain 1.7k
Adam Kennedy made you No 1 in the FAIL 100 at http://ali.as/top100/ so I did some regression testing of IO::Zlib against Compress::Zlib versions which revealed some version dependencies that might interest you: **************************************************************** Regression 'mod:Compress::Zlib' **************************************************************** Name Theta StdErr T-stat [0='const'] 1.0000 0.0074 135.21 [1='eq_1.41'] -1.0000 0.0850 -11.77 [2='eq_1.42'] -1.0000 0.0430 -23.27 [3='eq_1.4201'] -1.0000 0.0850 -11.77 [4='eq_2.003'] -0.3333 0.0695 -4.80 [5='eq_2.005'] -0.2857 0.0458 -6.23 [6='eq_2.006'] -0.0000 0.1199 -0.00 [7='eq_2.007'] -0.6667 0.0695 -9.59 [8='eq_2.008'] -0.0526 0.0108 -4.85 [9='eq_2.009'] -0.0000 0.0695 -0.00 [10='eq_2.010'] 0.0000 0.0386 0.00 [11='eq_2.011'] -0.0000 0.0213 -0.00 [12='eq_2.012'] -0.0000 0.0193 -0.00 [13='eq_2.015'] -0.0000 0.0108 -0.00 [14='eq_2.017'] -0.0000 0.0251 -0.00 [15='eq_2.019'] -0.0000 0.0197 -0.00 [16='eq_2.020'] -0.0000 0.0170 -0.00 [17='eq_n/a'] -0.0000 0.0218 -0.00 This means when you simply increase the dependency to 2.009 then all the FAILs on cpantesters are moot. I don't know if anybody still depends on the old Compress::Zlib versions, I looked up and found that 2.009 was released 20 April 2008. Seems like a time frame long enough to forget about the old failures. Let me know if you need more information. HTH & Regards,
Download (untitled) / with headers
text/plain 100b
And when you read the HTML source of this page then you actually get the table above aligned nicely.
Subject: Re: [rt.cpan.org #47793] Dependency on Compress::Zlib by version reveals that you need >= 2.009
Date: Mon, 13 Jul 2009 10:16:04 +0100
To: bug-IO-Zlib [...] rt.cpan.org
From: Tom Hughes <tom [...] compton.nu>
Download (untitled) / with headers
text/plain 599b
On 11/07/09 07:11, Andreas Koenig via RT wrote: Show quoted text
> so I did some regression testing of IO::Zlib against Compress::Zlib > versions which revealed some version dependencies that might interest you:
[ snip ] Show quoted text
> This means when you simply increase the dependency to 2.009 then all the > FAILs on cpantesters are moot.
Yes I know that, but when I tried to go down that route before I got grief from people using old versions of IO-Zlib. Given that most things do actually work with older versions I decided then not to change it I think. Tom -- Tom Hughes (tom@compton.nu) http://www.compton.nu/


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.