Skip Menu |
 

This queue is for tickets about the GD CPAN distribution.

Report information
The Basics
Id: 47653
Status: resolved
Priority: 0/
Queue: GD

People
Owner: Nobody in particular
Requestors: kurt [...] otown.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 2.43
Fixed in: (no value)



Subject: GD build failure on Darwin 9.7.0 (MacOS 10.5.7)
Download (untitled) / with headers
text/plain 2.8k
Distribution: L/LD/LDS/GD-2.43.tar.gz Perl Version: v5.8.8 built for darwin-thread-multi-2level OS: Darwin Kernel Version 9.7.0 (MacOS 10.5.7 Leopard) ================================== cpan[20]> force install GD Running install for module 'GD' Running make for L/LD/LDS/GD-2.43.tar.gz Has already been unwrapped into directory /Users/kurt/.cpan/build/GD-2.43-yKuKp6 Has already been made Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/GD.t ........ 1/12 Can't load './blib/arch/auto/GD/GD.bundle' for module GD: dlopen(./blib/arch/auto/GD/GD.bundle, 2): Symbol not found: _gdFTUseFontConfig Referenced from: /Users/kurt/.cpan/build/GD-2.43- yKuKp6/blib/arch/auto/GD/GD.bundle Expected in: dynamic lookup at t/GD.t line 14 Compilation failed in require at t/GD.t line 14. BEGIN failed--compilation aborted at t/GD.t line 14. t/GD.t ........ Dubious, test returned 2 (wstat 512, 0x200) Failed 12/12 subtests t/Polyline.t .. Can't load '/Users/kurt/.cpan/build/GD-2.43- yKuKp6/blib/arch/auto/GD/GD.bundle' for module GD: dlopen(/Users/kurt/.cpan/build/GD- 2.43-yKuKp6/blib/arch/auto/GD/GD.bundle, 2): Symbol not found: _gdFTUseFontConfig Referenced from: /Users/kurt/.cpan/build/GD-2.43- yKuKp6/blib/arch/auto/GD/GD.bundle Expected in: dynamic lookup at /Users/kurt/.cpan/build/GD-2.43-yKuKp6/blib/lib/GD/Polyline.pm line 45 Compilation failed in require at /Users/kurt/.cpan/build/GD-2.43- yKuKp6/blib/lib/GD/Polyline.pm line 45. BEGIN failed--compilation aborted at /Users/kurt/.cpan/build/GD-2.43- yKuKp6/blib/lib/GD/Polyline.pm line 45. Compilation failed in require at t/Polyline.t line 10. BEGIN failed--compilation aborted at t/Polyline.t line 10. t/Polyline.t .. Dubious, test returned 2 (wstat 512, 0x200) Failed 1/1 subtests Test Summary Report ------------------- t/GD.t (Wstat: 512 Tests: 1 Failed: 1) Failed test: 1 Non-zero exit status: 2 Parse errors: Bad plan. You planned 12 tests but ran 1. t/Polyline.t (Wstat: 512 Tests: 0 Failed: 0) Non-zero exit status: 2 Parse errors: Bad plan. You planned 1 tests but ran 0. Files=2, Tests=1, 1 wallclock secs ( 0.02 usr 0.01 sys + 0.06 cusr 0.02 csys = 0.11 CPU) Result: FAIL Failed 2/2 test programs. 1/1 subtests failed. gnumake: *** [test_dynamic] Error 2 LDS/GD-2.43.tar.gz /usr/bin/gnumake test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports LDS/GD-2.43.tar.gz Running make install Files found in blib/arch: installing files in blib/lib into architecture dependent library tree Appending installation info to /Library/Perl/Updates/5.8.8/darwin-thread-multi- 2level/perllocal.pod LDS/GD-2.43.tar.gz /usr/bin/gnumake install -- OK Failed during this command: LDS/GD-2.43.tar.gz : make_test FAILED but failure ignored because 'force' in effect cpan[21]>
Download (untitled) / with headers
text/plain 440b
On Tue Jul 07 12:02:44 2009, Kurta wrote: Show quoted text
> Distribution: L/LD/LDS/GD-2.43.tar.gz > Perl Version: v5.8.8 built for darwin-thread-multi-2level > OS: Darwin Kernel Version 9.7.0 (MacOS 10.5.7 Leopard)
Show quoted text
> dlopen(./blib/arch/auto/GD/GD.bundle, 2): Symbol not found: > _gdFTUseFontConfig
This comes from the feature FONTCONFIG which is not available on your system. Either install libfontconfig, or remove -DHAVE_FONTCONFIG from the Makefile.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.