Skip Menu |
 

This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id: 47629
Status: open
Priority: 0/
Queue: CPAN

People
Owner: Nobody in particular
Requestors: mschwern [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.9402
Fixed in: (no value)



Subject: "cpan ." does not install build_requires
Download (untitled) / with headers
text/plain 167b
I recently tried to install perl5i on a fresh install using "cpan .". It installed all the run time prereqs but ignored the build_requires so the module didn't build.
Subject: Re: [rt.cpan.org #47629] "cpan ." does not install build_requires
Date: Mon, 6 Jul 2009 17:59:03 -0400
To: bug-CPAN [...] rt.cpan.org
From: David Golden <dagolden [...] cpan.org>
Download (untitled) / with headers
text/plain 313b
On Mon, Jul 6, 2009 at 5:05 PM, Michael G Schwern via RT<bug-CPAN@rt.cpan.org> wrote: Show quoted text
> I recently tried to install perl5i on a fresh install using "cpan .". > It installed all the run time prereqs but ignored the build_requires so > the module didn't build.
"fresh install" of what? Perl -V, please. -- David
CC: mschwern [...] cpan.org
Subject: Re: [rt.cpan.org #47629] "cpan ." does not install build_requires
Date: Mon, 06 Jul 2009 16:23:02 -0700
To: bug-CPAN [...] rt.cpan.org
From: Michael G Schwern <schwern [...] pobox.com>
Download (untitled) / with headers
text/plain 631b
David Golden via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=47629 > > > On Mon, Jul 6, 2009 at 5:05 PM, Michael G Schwern via > RT<bug-CPAN@rt.cpan.org> wrote:
>> I recently tried to install perl5i on a fresh install using "cpan .". >> It installed all the run time prereqs but ignored the build_requires so >> the module didn't build.
> > "fresh install" of what? Perl -V, please.
The latest Strawberry (5.10.0.5) which I don't have in front of me at the moment. Its possible it got fixed very recently as I can't replicate with my 5.10.0 on OS X. I'll investigate. -- Defender of Lexical Encapsulation
Subject: Re: [rt.cpan.org #47629] "cpan ." does not install build_requires
Date: Mon, 6 Jul 2009 22:39:50 -0400
To: bug-CPAN [...] rt.cpan.org
From: David Golden <xdaveg [...] gmail.com>
Download (untitled) / with headers
text/plain 525b
On Mon, Jul 6, 2009 at 7:23 PM, Michael G Schwern via RT<bug-CPAN@rt.cpan.org> wrote: Show quoted text
>> "fresh install" of what?  Perl -V, please.
> > The latest Strawberry (5.10.0.5) which I don't have in front of me at the > moment.  Its possible it got fixed very recently as I can't replicate with my > 5.10.0 on OS X.
Try it with CPAN::SQLite turned off. That's been an off-and-on problem for dependency resolution in the past. I thought it was fixed, but I'd want to rule it out before you start chasing rabbit trails. -- David


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.