Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the DateTime-Format-Pg CPAN distribution.

Report information
The Basics
Id: 47604
Status: resolved
Priority: 0/
Queue: DateTime-Format-Pg

People
Owner: Nobody in particular
Requestors: TJC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.16003
Fixed in: 0.16004



Subject: Empty META.yml prevents installation
Download (untitled) / with headers
text/plain 604b
The META.yml shipped in version 0.16003 is empty. This causes an error to occur when attempting to install the module via CPANPLUS! CPAN Terminal> i DateTime::Format::Pg Installing DateTime::Format::Pg (0.16003) [ERROR] Could not read /home/tobyc/.cpanplus/5.10.0/build/DateTime-Format-Pg-0.16003/META.yml: '' Key 'prereqs' needs to be of type 'HASH' at /home/tobyc/perl/lib/perl/CPANPLUS/Module.pm line 812 [ERROR] Unable to satisfy 'configure_requires' for 'DateTime::Format::Pg' -- aborting install [ERROR] Unable to create a new distribution object for 'DateTime::Format::Pg' -- cannot continue
Download (untitled) / with headers
text/plain 209b
Release 0.16004 has resolved the issue by including a valid META.yml I have opened a ticket on the part of CPANPLUS that handles reading META.yml to suggest it has a more graceful failure mode for such cases.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.