Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Archive-Zip CPAN distribution.

Report information
The Basics
Id:
47454
Status:
open
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
configserver [...] googlemail.com
Cc:
AdminCc:

BugTracker
Severity:
(no value)
Broken in:
1.29
Fixed in:
1.30

Attachments


Subject: v1.29 Bareword "Cwd::getcwd" not allowed while "strict subs" in use
Date: Tue, 30 Jun 2009 10:45:12 +0100
To: bug-Archive-Zip@rt.cpan.org
From: Jonathan Michaelson <configserver@googlemail.com>
v1.29 of Archive::Zip breaks the MailScanner application.

Running on perl v5.8.8 on CentOS v5.3:

Bareword "Cwd::getcwd" not allowed while "strict subs" in use at /usr/lib/perl5/site_perl/5.8.8/Archive/Zip.pm line 552.
Compilation failed in require at /usr/mailscanner/lib/MailScanner/Message.pm line 48.
BEGIN failed--compilation aborted at /usr/mailscanner/lib/MailScanner/Message.pm line 48.
Compilation failed in require at /usr/mailscanner/bin/MailScanner line 107.
BEGIN failed--compilation aborted at /usr/mailscanner/bin/MailScanner line 107.

This worked fine in Archive::Zip v1.28 and also works if you add the following into Zip.pm:

use strict;
no  strict 'subs';

On Tue Jun 30 05:45:41 2009, configserver@googlemail.com wrote:
Show quoted text
> v1.29 of Archive::Zip breaks the MailScanner application. > > Running on perl v5.8.8 on CentOS v5.3: > > Bareword "Cwd::getcwd" not allowed while "strict subs" in use at > /usr/lib/perl5/site_perl/5.8.8/Archive/Zip.pm line 552. > Compilation failed in require at
/usr/mailscanner/lib/MailScanner/Message.pm
Show quoted text
> line 48. > BEGIN failed--compilation aborted at > /usr/mailscanner/lib/MailScanner/Message.pm line 48. > Compilation failed in require at /usr/mailscanner/bin/MailScanner line
107.
Show quoted text
> BEGIN failed--compilation aborted at /usr/mailscanner/bin/MailScanner line > 107. > > This worked fine in Archive::Zip v1.28 and also works if you add the > following into Zip.pm: > > use strict; > no strict 'subs';
This affects perl 5.8.6 on Fedora 4, 5.8.8 on Fedora 5 through 8, and 5.8.8 on RHEL 5. Unaffected are perl 5.8.6 and earlier releases on older Fedoras, 5.10.0 on current Fedora releases, 5.8.0 on RHEL 3, and 5.8.5 on RHEL 4. Attached patch works across all of the above releases and is used in my RPMs here: http://mirror.city-fan.org/ftp/contrib/perl-modules/
--- Archive-Zip-1.29/lib/Archive/Zip.pm 2009-06-29 14:24:59.000000000 +0100 +++ Archive-Zip-1.29/lib/Archive/Zip.pm 2009-06-30 09:37:33.000000000 +0100 @@ -549,7 +549,7 @@ my $localName = File::Spec->catpath( $volume, $localDirs, $filename ); require Cwd; unless ( $volume ) { - $localName = File::Spec->rel2abs( $localName, Cwd::getcwd ); + $localName = File::Spec->rel2abs( $localName, Cwd::getcwd() ); } return $localName; }
Subject: Re: [rt.cpan.org #47454] v1.29 Bareword "Cwd::getcwd" not allowed while "strict subs" in use
Date: Thu, 2 Jul 2009 02:08:18 +1000
To: bug-Archive-Zip@rt.cpan.org
From: Adam Kennedy <adamkennedybackup@gmail.com>
Resolved in 1.30. Thank you for the report (and sorry for the oversight) 2009/6/30 paul@city-fan.org via RT <bug-Archive-Zip@rt.cpan.org>:
Show quoted text
>       Queue: Archive-Zip >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=47454 > > > On Tue Jun 30 05:45:41 2009, configserver@googlemail.com wrote:
>> v1.29 of Archive::Zip breaks the MailScanner application. >> >> Running on perl v5.8.8 on CentOS v5.3: >> >> Bareword "Cwd::getcwd" not allowed while "strict subs" in use at >> /usr/lib/perl5/site_perl/5.8.8/Archive/Zip.pm line 552. >> Compilation failed in require at
> /usr/mailscanner/lib/MailScanner/Message.pm
>> line 48. >> BEGIN failed--compilation aborted at >> /usr/mailscanner/lib/MailScanner/Message.pm line 48. >> Compilation failed in require at /usr/mailscanner/bin/MailScanner line
> 107.
>> BEGIN failed--compilation aborted at /usr/mailscanner/bin/MailScanner line >> 107. >> >> This worked fine in Archive::Zip v1.28 and also works if you add the >> following into Zip.pm: >> >> use strict; >> no  strict 'subs';
> > This affects perl 5.8.6 on Fedora 4, 5.8.8 on Fedora 5 through 8, and > 5.8.8 on RHEL 5. Unaffected are perl 5.8.6 and earlier releases on older > Fedoras, 5.10.0 on current Fedora releases, 5.8.0 on RHEL 3, and 5.8.5 > on RHEL 4. > > Attached patch works across all of the above releases and is used in my > RPMs here: http://mirror.city-fan.org/ftp/contrib/perl-modules/ > >


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.