Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 47394
Status: resolved
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: user42 [...] zip.com.au
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)

Attachments


Subject: 5.010 operators
Date: Sun, 28 Jun 2009 09:24:39 +1000
To: bug-Perl-MinimumVersion [...] rt.cpan.org
From: Kevin Ryde <user42 [...] zip.com.au>
Download (untitled) / with headers
text/plain 342b
With Perl::MinimumVersion 1.20 and recent debian perl 5.010 a program use Perl::MinimumVersion; print Perl::MinimumVersion->new(\'1 // 2')->minimum_version; prints 5.004, where I hoped it would be 5.010 due to the use of the // operator. Perhaps the change below (Magic and Operator the opposite way around for their tests ...).
--- MinimumVersion.pm.orig 2009-06-18 09:04:14.000000000 +1000 +++ MinimumVersion.pm 2009-06-18 09:05:12.000000000 +1000 @@ -440,7 +440,7 @@ sub _perl_5010_operators { shift->Document->find_any( sub { - $_[1]->isa('PPI::Token::Magic') + $_[1]->isa('PPI::Token::Operator') and $MATCHES{_perl_5010_operators}->{$_[1]->content} } ); @@ -448,7 +448,7 @@ sub _perl_5010_magic { shift->Document->find_any( sub { - $_[1]->isa('PPI::Token::Operator') + $_[1]->isa('PPI::Token::Magic') and $MATCHES{_perl_5010_magic}->{$_[1]->content} } );
Subject: Re: [rt.cpan.org #47394] 5.010 operators
Date: Mon, 29 Jun 2009 13:43:08 +1000
To: bug-Perl-MinimumVersion [...] rt.cpan.org
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
Download (untitled) / with headers
text/plain 938b
This probably wants to wait for the next prod release of PPI (which has more complete support for Perl 5.10) Adam K 2009/6/28 Kevin Ryde via RT <bug-Perl-MinimumVersion@rt.cpan.org>: Show quoted text
> Sat Jun 27 19:25:10 2009: Request 47394 was acted upon. > Transaction: Ticket created by user42@zip.com.au >       Queue: Perl-MinimumVersion >     Subject: 5.010 operators >   Broken in: (no value) >    Severity: (no value) >       Owner: Nobody >  Requestors: user42@zip.com.au >      Status: new >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=47394 > > > > With Perl::MinimumVersion 1.20 and recent debian perl 5.010 a program > >    use Perl::MinimumVersion; >    print Perl::MinimumVersion->new(\'1 // 2')->minimum_version; > > prints 5.004, where I hoped it would be 5.010 due to the use of the // > operator.  Perhaps the change below (Magic and Operator the opposite way > around for their tests ...). > > > >
Subject: Re: [rt.cpan.org #47394] 5.010 operators
Date: Tue, 30 Jun 2009 09:46:54 +1000
To: bug-Perl-MinimumVersion [...] rt.cpan.org
From: Kevin Ryde <user42 [...] zip.com.au>
Download (untitled) / with headers
text/plain 333b
"Reserved Local Account via RT" <bug-Perl-MinimumVersion@rt.cpan.org> writes: Show quoted text
> > This probably wants to wait for the next prod release of PPI (which > has more complete support for Perl 5.10)
It's not merely Perl::MinimumVersion with the two class names the wrong way around? Ie. current PPI is fine, just what it's doing itself?
Subject: Re: [rt.cpan.org #47394] 5.010 operators
Date: Thu, 03 Dec 2009 09:08:44 +1100
To: bug-Perl-MinimumVersion [...] rt.cpan.org
From: Kevin Ryde <user42 [...] zip.com.au>
Download (untitled) / with headers
text/plain 205b
I wrote: Show quoted text
> > - $_[1]->isa('PPI::Token::Magic') > + $_[1]->isa('PPI::Token::Operator')
This is still present in 1.22. I'm now sure it's merely the two token names the wrong way around in the two tests.
RT-Send-CC: adamkennedybackup [...] gmail.com
Download (untitled) / with headers
text/plain 1.1k
PPI 1.205 was released, but this issue was still not fixed yet. Please apply patch and release it :) On 2009-6月-28 日 23:43:32, adam@ali.as wrote: Show quoted text
> This probably wants to wait for the next prod release of PPI (which > has more complete support for Perl 5.10) > > Adam K > > 2009/6/28 Kevin Ryde via RT <bug-Perl-MinimumVersion@rt.cpan.org>:
> > Sat Jun 27 19:25:10 2009: Request 47394 was acted upon. > > Transaction: Ticket created by user42@zip.com.au > >       Queue: Perl-MinimumVersion > >     Subject: 5.010 operators > >   Broken in: (no value) > >    Severity: (no value) > >       Owner: Nobody > >  Requestors: user42@zip.com.au > >      Status: new > >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=47394 > > > > > > > With Perl::MinimumVersion 1.20 and recent debian perl 5.010 a program > > > >    use Perl::MinimumVersion; > >    print Perl::MinimumVersion->new(\'1 // 2')->minimum_version; > > > > prints 5.004, where I hoped it would be 5.010 due to the use of the // > > operator.  Perhaps the change below (Magic and Operator the opposite way > > around for their tests ...). > > > > > > > >
Resolved in Perl::MinimumVersion 1.28


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.