Skip Menu |
 

This queue is for tickets about the Catalyst-Authentication-Credential-HTTP CPAN distribution.

Report information
The Basics
Id: 47098
Status: open
Priority: 0/
Queue: Catalyst-Authentication-Credential-HTTP

People
Owner: bobtfish [...] bobtfish.net
Requestors: bpphillips+bitcard [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)



Subject: not compatible with Catalyst::Authentication::Realm::Progressive
Download (untitled) / with headers
text/plain 666b
since the Catalyst::Authentication::Credential::HTTP::authenticate sub die's (triggering a detach) if it's not able to successfully authenticate, it's not possible to use this as part of a set of progressive realms since the die is not caught and the loop over the progressive realms is aborted. It would be nice to be able to specify a configuration flag that would tell this module not to short-circuit the authentication process. This would require the controller to manually call the "authentication_required_response" method but this is likely desirable anyway since one might want to tweak the realm name to match the generic progressive realm name.
Download (untitled) / with headers
text/plain 127b
Yes, that'd be totally useful, and would be very simple to add. Don't suppose you'd like to try to produce a patch to do this?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.