Skip Menu |
 

This queue is for tickets about the CPANPLUS-Dist-Deb CPAN distribution.

Report information
The Basics
Id: 46978
Status: new
Priority: 0/
Queue: CPANPLUS-Dist-Deb

People
Owner: Nobody in particular
Requestors: CRAKRJACK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: check "module_is_supplied_with_perl_core" as well as "package_is_perl_core"
Download (untitled) / with headers
text/plain 214b
A lot of my generated modules are depending on things like "libio-perl", "libextutils-makemaker-perl", etc, even though they don't need to. A check for "module_is_supplied_with_perl_core" could help prevent this.
Download (untitled) / with headers
text/plain 775b
one other note -- I wanted to override this logic in CPANPLUS::Dist::Deb (since I have an immediate need), but I can't do that easily because since prepare() is a huge method that does a bunch of other stuff. you should consider moving the whole prereqs() loop into a method or two, eg; sub prepare { {.....} my @depends = $self->prereqs; {.....} } sub prereqs { my $self = shift; my $prereqs = $self->status->prereqs; my @depends; for my $prereq ( sort keys %$prereqs ) { push(@depends, $self->prereq_depends($prereq)); } return @depends; } sub prereq_depends { {.....} } actually, it'd be helpful to break most of Deb.pm down into smaller bits since there's often "weird" packages that need special treatment to debianize (like Crypt::IDEA)...


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.