This queue is for tickets about the Class-Accessor-Grouped CPAN distribution.

Report information
The Basics
Id:
46872
Status:
resolved
Priority:
Low/Low

People
Owner:
claco [...] cpan.org (email delivery suspended)
Requestors:
TJC [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.08003
Fixed in:
(no value)



Subject: Seems to require Class::C3 to pass tests
Sorry if this is a bit vague.. I was attempting to install some modules on a fresh Debian 4 box, and cpanplus failed on Class::Accessor::Grouped's tests, with an error about Class::C3 not found. Installing Class::C3 manually, then re-testing CAG had the tests pass. Might be a missing dependency in Makefile.PL perhaps?
Can't seem to reproduces this. $ ack C3 doesn't yield and direct use of Class::C3 in and dist code. I suspect you were on a perl < 5.10, and Class::C3 is listed as an optional prereq for MRO::Compat.
On Tue Jul 07 22:43:10 2009, CLACO wrote:
Show quoted text
> Can't seem to reproduces this. > > $ ack C3 > > doesn't yield and direct use of Class::C3 in and dist code. > > I suspect you were on a perl < 5.10, and Class::C3 is listed as an > optional prereq for MRO::Compat.
You are correct that Debian 4 runs Perl 5.8.8. So if the bug isn't in this module, is the bug in CPANPLUS or CPAN then for not following a dependency? All prior modules in the dependency chain passed their own unit tests up until this one. (Background: I've been trying to get Catalyst+DBIC+Moose to install onto "fresh" Win32, Win64, Linux x86, Linux AMD64 boxes, and raising a number of RT tickets so far on modules that fail during the process.)
You're correct though.. CAG requires MRO::Compat, and it requires Class::C3. So this bug should stay resolved. I'll try and figure out what's going on. Thanks for your help.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.