This queue is for tickets about the Module-Build-TAPArchive CPAN distribution.

Report information
The Basics
Id:
46632
Status:
open
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
JSWARTZ [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
  • 0.02
  • 0.03
  • 0.04
Fixed in:
(no value)



Test failures when installing under perl 5.8.8 on both OS X and Linux, for both 0.02 and 0.03. Creating new 'Build' script for 'Module-Build-TAPArchive' version '0.03' Copying lib/Module/Build/TAPArchive.pm -> blib/lib/Module/Build/TAPArchive.pm Manifying blib/lib/Module/Build/TAPArchive.pm -> blib/libdoc/Module::Build::TAPArchive.3 WONKO/Module-Build-TAPArchive-0.03.tar.gz ./Build -- OK Running Build test t/00-load.t .. ok t/01-base.t .. 1/14 # Failed test 'right number of passed tests' # at t/01-base.t line 51. # got: '0' # expected: '3' # Failed test 'right number of failed tests' # at t/01-base.t line 52. # got: '0' # expected: '1' # Looks like you failed 2 tests of 14.
On Tue Jun 02 18:34:14 2009, JSWARTZ wrote:
Show quoted text
> Test failures when installing under perl 5.8.8 on both OS X and Linux, > for both 0.02 and 0.03.
Can you run those tests with --verbose so I can see more of what is happening? Also what versions of the prereqs (Module::Build, TAP::Harness::Archive, Test::More, Capture::Tiny and File::Path) do you have?
Subject: Re: [rt.cpan.org #46632]
Date: Tue, 2 Jun 2009 15:55:22 -0700
To: bug-Module-Build-TAPArchive@rt.cpan.org
From: Jonathan Swartz <swartz@pobox.com>
Show quoted text
swartz> ./Build test --verbose
t/00-load....1..1 ok 1 - use Module::Build::TAPArchive; ok t/01-base....1..14 ok 1 - use Module::Build::TAPArchive; ok 2 - Module::Build::TAPArchive->can('new') Checking prerequisites... Looks good ok 3 - The object isa Module::Build ok 4 - The object isa Module::Build::TAPArchive ok 5 - default archive_file is test_archive.tar.gz Checking prerequisites... Looks good ok 6 - The object isa Module::Build ok 7 - The object isa Module::Build::TAPArchive ok 8 - override archive_file ok 9 - Module::Build::TAPArchive->can('ACTION_test') ok 10 - Module::Build::TAPArchive->can('ACTION_test_archive') ok 11 - created archive file ok 12 - The object isa TAP::Parser::Aggregator not ok 13 - right number of passed tests # Failed test 'right number of passed tests' # at t/01-base.t line 51. # got: '0' # expected: '3' not ok 14 - right number of failed tests # Failed test 'right number of failed tests' # at t/01-base.t line 52. # got: '0' # expected: '1' # Looks like you failed 2 tests of 14. dubious Test returned status 2 (wstat 512, 0x200) DIED. FAILED tests 13-14 Failed 2/14 tests, 85.71% okay Failed Test Stat Wstat Total Fail List of Failed ---------------------------------------------------------------------------------------------------------------------------------------------- t/01-base.t 2 512 14 2 13-14 Failed 1/2 test scripts. 2/15 subtests failed. Files=2, Tests=15, 1 wallclock secs ( 0.52 cusr + 0.15 csys = 0.67 CPU) Failed 1/2 test programs. 2/15 subtests failed.
Show quoted text
swartz> findpm Module::Build TAP::Harness::Archive Test::More
Capture::Tiny File::Path Module::Build - 0.33 - /Library/Perl/5.8.8/Module/Build.pm TAP::Harness::Archive - 0.13 - /Library/Perl/5.8.8/TAP/Harness/ Archive.pm Test::More - 0.86 - /System/Library/Perl/5.8.8/Test/More.pm Capture::Tiny - 0.06 - /Library/Perl/5.8.8/Capture/Tiny.pm File::Path - 1.08 - /System/Library/Perl/5.8.8/File/Path.pm
Show quoted text
swartz>
I upgraded to the latest versions of those modules, still fails in the same way.
Show quoted text
swartz> findpm Module::Build TAP::Harness::Archive Test::More
Capture::Tiny File::Path Module::Build - 0.33 - /Library/Perl/5.8.8/Module/Build.pm TAP::Harness::Archive - 0.13 - /Library/Perl/5.8.8/TAP/Harness/ Archive.pm Test::More - 0.88 - /System/Library/Perl/5.8.8/Test/More.pm Capture::Tiny - 0.06 - /Library/Perl/5.8.8/Capture/Tiny.pm File::Path - 2.07 - /System/Library/Perl/5.8.8/File/Path.pm On Jun 2, 2009, at 3:39 PM, Michael Peters via RT wrote:
Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=46632 > > > On Tue Jun 02 18:34:14 2009, JSWARTZ wrote:
>> Test failures when installing under perl 5.8.8 on both OS X and >> Linux, >> for both 0.02 and 0.03.
> > Can you run those tests with --verbose so I can see more of what is > happening? Also what versions of the prereqs (Module::Build, > TAP::Harness::Archive, Test::More, Capture::Tiny and File::Path) do > you > have? > >
JFYI: same problem building v0.03 with Perl 5.10.0 prereq versions: Module::Build 0.3300 TAP::Harness::Archive 0.13 Test::More 3.17 Capture::Tiny 0.06 File::Path 2.07
On 2009-08-04 08:33:46, snowcrash78 wrote:
Show quoted text
> JFYI: same problem building v0.03 with Perl 5.10.0 > > prereq versions: > Module::Build 0.3300 > TAP::Harness::Archive 0.13 > Test::More 3.17 > Capture::Tiny 0.06 > File::Path 2.07
With 0.04 the test also fails: Errors in testing. Cannot continue. # Looks like your test exited with 29 just after 10. t/01-base.t .. Dubious, test returned 29 (wstat 7424, 0x1d00) Failed 4/14 subtests


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.