Skip Menu |
 

This queue is for tickets about the DBIx-Class CPAN distribution.

Report information
The Basics
Id: 45968
Status: resolved
Priority: 0/
Queue: DBIx-Class

People
Owner: Nobody in particular
Requestors: jettero [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 0.08103



Subject: build fail (I'm not in CPANPLUS)
Download (untitled) / with headers
text/plain 922b
I'd have reported this via CPAN::Reporter, but I can't because it's precisely the Prerequisites that are failing. the Module::Install gizmo thinks I'm running under CPANPLUS and I am not, so it fails to install the pre-reqs, of which I'm missing 5. My installation is not exotic, it's ubuntu 8.04 perl 5.8.8 -- mo idea what's gone wrong. CPAN::Reporter: test results were not valid, Prerequisite version too low. RIBASUSHI/DBIx-Class-0.08102.tar.gz /usr/bin/make test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports RIBASUSHI/DBIx-Class-0.08102.tar.gz Running make install make test had returned bad status, won't install without force Failed during this command: RIBASUSHI/DBIx-Class-0.08102.tar.gz : make_test NO -- If riding in an airplane is flying, then riding in a boat is swimming. 107 jumps, 43.5 minutes of freefall, 83.4 freefall miles.
Download (untitled) / with headers
text/plain 670b
On Mon May 11 14:23:19 2009, JETTERO wrote: Show quoted text
> I'd have reported this via CPAN::Reporter, but I can't because it's > precisely the Prerequisites that are failing. the Module::Install gizmo > thinks I'm running under CPANPLUS and I am not, so it fails to install > the pre-reqs, of which I'm missing 5. > > My installation is not exotic, it's ubuntu 8.04 perl 5.8.8 -- mo idea > what's gone wrong.
Can you report what happens if you just download the tar, untar it and run perl Makefile.PL make make test (no make install) Also while in the same directory, please give the output of the following (after running the above): perl -Minc::Module::Install\ 999 Thanks
Download (untitled) / with headers
text/plain 2.7k
On Tue May 12 05:57:00 2009, RIBASUSHI wrote: Show quoted text
> On Mon May 11 14:23:19 2009, JETTERO wrote: > perl Makefile.PL
Script started on Tue 12 May 2009 06:31:08 AM EDT bash# perl Makefile.PL *** Module::AutoInstall version 1.03 *** Checking for Perl dependencies... [Core Features] - Test::Builder ...loaded. (0.86 >= 0.33) - Test::Warn ...loaded. (0.11 >= 0.11) - Test::Exception ...loaded. (0.27) - Test::Deep ...loaded. (0.103) - DBD::SQLite ...missing. (would need 1.23) - Data::Page ...loaded. (2.00 >= 2) - Scalar::Util ...loaded. (1.19) - SQL::Abstract ...missing. (would need 1.51) - SQL::Abstract::Limit ...loaded. (0.141 >= 0.13) - Class::C3::Componentised ...missing. (would need 1.0005) - Storable ...loaded. (2.18) - Carp::Clan ...loaded. (6.00) - DBI ...loaded. (1.607 >= 1.4) - Module::Find ...loaded. (0.06) - Class::Inspector ...loaded. (1.23) - Class::Accessor::Grouped ...loaded. (0.08003 >= 0.08003) - JSON::Any ...loaded. (1.19 >= 1.17) - Scope::Guard ...loaded. (0.03 >= 0.03) - Path::Class ...loaded. (0.16) - List::Util ...loaded. (1.19 >= 1.19) - Sub::Name ...loaded. (0.04 >= 0.04) - MRO::Compat ...loaded. (0.09 >= 0.09) ==> Auto-install the 3 mandatory module(s) from CPAN? [y] *** Since we're running under CPANPLUS, I'll just let it take care of the dependency's installation later. *** Module::AutoInstall configuration finished. Checking if your kit is complete... Looks good Warning: prerequisite Class::C3::Componentised 1.0005 not found. We have 1.0003. Warning: prerequisite DBD::SQLite 1.23 not found. We have 1.14. Warning: prerequisite SQL::Abstract 1.51 not found. We have 1.24. Writing Makefile for DBIx::Class bash# exit Show quoted text
> perl -Minc::Module::Install\ 999
inc::Module::Install version 999 required--this is only version 0.79. Show quoted text
> make > make test
I'm going to skip this step because it's become completely obvious to me the bug is elsewhere. I was working in a chroot (a full ubuntu 8.04, but still) and the behavior there is entirely different form what I'm seeing on my main PC. M::I still claims I'm in CPANPLUS, but requires in the deps just fine. I'm presently thinking it was an older, or newer-but-buggy version of Module::Install. Looking above, it seems the Makefile.PL picks the newer M::I if available? I'm going to go back into that chroot and dig a little deeper. I think it's safe to say it's not a DBIx::Class bug in any case. -- If riding in an airplane is flying, then riding in a boat is swimming. 107 jumps, 43.5 minutes of freefall, 83.4 freefall miles.
On Tue May 12 06:44:23 2009, JETTERO wrote: Show quoted text
> On Tue May 12 05:57:00 2009, RIBASUSHI wrote:
> > On Mon May 11 14:23:19 2009, JETTERO wrote: > > perl Makefile.PL
> > Script started on Tue 12 May 2009 06:31:08 AM EDT > bash# perl Makefile.PL > *** Module::AutoInstall version 1.03 > *** Checking for Perl dependencies... > [Core Features] > - Test::Builder ...loaded. (0.86 >= 0.33) > - Test::Warn ...loaded. (0.11 >= 0.11) > - Test::Exception ...loaded. (0.27) > - Test::Deep ...loaded. (0.103) > - DBD::SQLite ...missing. (would need 1.23) > - Data::Page ...loaded. (2.00 >= 2) > - Scalar::Util ...loaded. (1.19) > - SQL::Abstract ...missing. (would need 1.51) > - SQL::Abstract::Limit ...loaded. (0.141 >= 0.13) > - Class::C3::Componentised ...missing. (would need 1.0005) > - Storable ...loaded. (2.18) > - Carp::Clan ...loaded. (6.00) > - DBI ...loaded. (1.607 >= 1.4) > - Module::Find ...loaded. (0.06) > - Class::Inspector ...loaded. (1.23) > - Class::Accessor::Grouped ...loaded. (0.08003 >= 0.08003) > - JSON::Any ...loaded. (1.19 >= 1.17) > - Scope::Guard ...loaded. (0.03 >= 0.03) > - Path::Class ...loaded. (0.16) > - List::Util ...loaded. (1.19 >= 1.19) > - Sub::Name ...loaded. (0.04 >= 0.04) > - MRO::Compat ...loaded. (0.09 >= 0.09) > ==> Auto-install the 3 mandatory module(s) from CPAN? [y] > > *** Since we're running under CPANPLUS, I'll just let it take care > of the dependency's installation later. > *** Module::AutoInstall configuration finished. > Checking if your kit is complete... > Looks good > Warning: prerequisite Class::C3::Componentised 1.0005 not found. We have > 1.0003. > Warning: prerequisite DBD::SQLite 1.23 not found. We have 1.14. > Warning: prerequisite SQL::Abstract 1.51 not found. We have 1.24. > Writing Makefile for DBIx::Class > bash# exit >
> > perl -Minc::Module::Install\ 999
> > inc::Module::Install version 999 required--this is only version 0.79. >
> > make > > make test
> > I'm going to skip this step because it's become completely obvious to me > the bug is elsewhere. I was working in a chroot (a full ubuntu 8.04, > but still) and the behavior there is entirely different form what I'm > seeing on my main PC. > > M::I still claims I'm in CPANPLUS, but requires in the deps just fine. > > I'm presently thinking it was an older, or newer-but-buggy version of > Module::Install. Looking above, it seems the Makefile.PL picks the > newer M::I if available? > > I'm going to go back into that chroot and dig a little deeper. > > I think it's safe to say it's not a DBIx::Class bug in any case. >
We are actually in he process of fixing M::I to be able to deal with this properly (we got to somewhat maintain M::I::Autoinstall). Please try with this tarball, and post the output of the same procedure: http://rabbit.us/diff/DBIx-Class-0.08102.tar.gz
Download (untitled) / with headers
text/plain 2.5k
On Tue May 12 06:51:25 2009, RIBASUSHI wrote: Show quoted text
> We are actually in he process of fixing M::I to be able to deal with > this properly (we got to somewhat maintain M::I::Autoinstall).
Which problem? "This" is the false CPANPLUS detection or the dep-require problem? Or are they indeed related? Show quoted text
> Please try with this tarball, and post the output of the same procedure: > http://rabbit.us/diff/DBIx-Class-0.08102.tar.gz
(I ruined my DBD::SQLite so it'd have something to require.) perl Makefile.PL *** Module::AutoInstall version 1.03 *** Checking for Perl dependencies... [Core Features] - Test::Builder ...loaded. (0.86 >= 0.33) - Test::Warn ...loaded. (0.11 >= 0.11) - Test::Exception ...loaded. (0.27) - Test::Deep ...loaded. (0.103) - DBD::SQLite ...missing. (would need 1.23) - Data::Page ...loaded. (2.00 >= 2) - Scalar::Util ...loaded. (1.19) - SQL::Abstract ...loaded. (1.54 >= 1.54) - SQL::Abstract::Limit ...loaded. (0.141 >= 0.13) - Class::C3::Componentised ...loaded. (1.0005 >= 1.0005) - Storable ...loaded. (2.18) - Carp::Clan ...loaded. (6.00) - DBI ...loaded. (1.607 >= 1.4) - Module::Find ...loaded. (0.06) - Class::Inspector ...loaded. (1.23) - Class::Accessor::Grouped ...loaded. (0.08003 >= 0.08003) - JSON::Any ...loaded. (1.19 >= 1.17) - Scope::Guard ...loaded. (0.03 >= 0.03) - Path::Class ...loaded. (0.16) - List::Util ...loaded. (1.19 >= 1.19) - Sub::Name ...loaded. (0.04 >= 0.04) - MRO::Compat ...loaded. (0.09 >= 0.09) ==> Auto-install the 1 mandatory module(s) from CPAN? [y] *** Dependencies will be installed the next time you type 'make'. (You may need to do that as the 'root' user.) *** Module::AutoInstall configuration finished. Had to create DBD::SQLite::dr::imp_data_size unexpectedly at /usr/local/lib/perl/5.8.8/DBI.pm line 1212, <STDIN> line 1. Had to create DBD::SQLite::db::imp_data_size unexpectedly at /usr/local/lib/perl/5.8.8/DBI.pm line 1242, <STDIN> line 1. Undefined subroutine &DBD::SQLite::db::_login called at /usr/local/lib/perl/5.8.8/DBD/SQLite.pm line 96, <STDIN> line 1. Warning: prerequisite DBD::SQLite 1.23 not found. We have 0.25. Writing Makefile for DBIx::Class Do you actually need the make/make install? -- If riding in an airplane is flying, then riding in a boat is swimming. 107 jumps, 43.5 minutes of freefall, 83.4 freefall miles.
Download (untitled) / with headers
text/plain 2.7k
On Tue May 12 07:01:53 2009, JETTERO wrote: Show quoted text
> On Tue May 12 06:51:25 2009, RIBASUSHI wrote:
> > We are actually in he process of fixing M::I to be able to deal with > > this properly (we got to somewhat maintain M::I::Autoinstall).
> > Which problem? "This" is the false CPANPLUS detection or the > dep-require problem? Or are they indeed related?
It's all related in one steaming pile of sh** Show quoted text
> > Please try with this tarball, and post the output of the same procedure: > > http://rabbit.us/diff/DBIx-Class-0.08102.tar.gz
> > (I ruined my DBD::SQLite so it'd have something to require.) > > perl Makefile.PL > *** Module::AutoInstall version 1.03 > *** Checking for Perl dependencies... > [Core Features] > - Test::Builder ...loaded. (0.86 >= 0.33) > - Test::Warn ...loaded. (0.11 >= 0.11) > - Test::Exception ...loaded. (0.27) > - Test::Deep ...loaded. (0.103) > - DBD::SQLite ...missing. (would need 1.23) > - Data::Page ...loaded. (2.00 >= 2) > - Scalar::Util ...loaded. (1.19) > - SQL::Abstract ...loaded. (1.54 >= 1.54) > - SQL::Abstract::Limit ...loaded. (0.141 >= 0.13) > - Class::C3::Componentised ...loaded. (1.0005 >= 1.0005) > - Storable ...loaded. (2.18) > - Carp::Clan ...loaded. (6.00) > - DBI ...loaded. (1.607 >= 1.4) > - Module::Find ...loaded. (0.06) > - Class::Inspector ...loaded. (1.23) > - Class::Accessor::Grouped ...loaded. (0.08003 >= 0.08003) > - JSON::Any ...loaded. (1.19 >= 1.17) > - Scope::Guard ...loaded. (0.03 >= 0.03) > - Path::Class ...loaded. (0.16) > - List::Util ...loaded. (1.19 >= 1.19) > - Sub::Name ...loaded. (0.04 >= 0.04) > - MRO::Compat ...loaded. (0.09 >= 0.09) > ==> Auto-install the 1 mandatory module(s) from CPAN? [y] > *** Dependencies will be installed the next time you type 'make'. > (You may need to do that as the 'root' user.) > *** Module::AutoInstall configuration finished. > Had to create DBD::SQLite::dr::imp_data_size unexpectedly at > /usr/local/lib/perl/5.8.8/DBI.pm line 1212, <STDIN> line 1. > Had to create DBD::SQLite::db::imp_data_size unexpectedly at > /usr/local/lib/perl/5.8.8/DBI.pm line 1242, <STDIN> line 1. > Undefined subroutine &DBD::SQLite::db::_login called at > /usr/local/lib/perl/5.8.8/DBD/SQLite.pm line 96, <STDIN> line 1. > Warning: prerequisite DBD::SQLite 1.23 not found. We have 0.25. > Writing Makefile for DBIx::Class >
So... this error is from a failing SQLite install or...? I am not sure if what I gave you actually solved your problem (the tarball contained a newer not-yet-released M::I version).
On Tue May 12 07:07:23 2009, RIBASUSHI wrote: Show quoted text
> So... this error is from a failing SQLite install or...?
Where I've been running these commands most recently I had all the deps up to date from the last time I ran "install DBIx::Class", so I went back and ruined DBD::SQLite so the Makefile.PL would have some deps to require in. Show quoted text
> if what I gave you actually solved your problem
It depends on how you look at it. On most CPAN.pm, the require warnings were working even when M::I thinks I'm in CPANPLUS. On whatever pairs of CPAN.pm+M::I I had in that chroot(), something was malfunctioning, ... dunno what for sure. The chroot() is a real ubuntu 8.04, it's just really lightly installed. But with your new and improved inc/M::I, it didn't seem to think I was in CPANPLUS, so that's good. Now that I'm at work I can try running both of the DBIx::Class tarballs (from CPAN and from the url above) inside my chroot() area if you think that would be helpful. -- If riding in an airplane is flying, then riding in a boat is swimming. 107 jumps, 43.5 minutes of freefall, 83.4 freefall miles.
Download (untitled) / with headers
text/plain 1.1k
On Tue May 12 09:05:51 2009, JETTERO wrote: Show quoted text
> On Tue May 12 07:07:23 2009, RIBASUSHI wrote:
> > So... this error is from a failing SQLite install or...?
> > Where I've been running these commands most recently I had all the deps > up to date from the last time I ran "install DBIx::Class", so I went > back and ruined DBD::SQLite so the Makefile.PL would have some deps to > require in. >
> > if what I gave you actually solved your problem
> > It depends on how you look at it. On most CPAN.pm, the require warnings > were working even when M::I thinks I'm in CPANPLUS. On whatever pairs > of CPAN.pm+M::I I had in that chroot(), something was malfunctioning, > ... dunno what for sure. > > The chroot() is a real ubuntu 8.04, it's just really lightly installed. > > But with your new and improved inc/M::I, it didn't seem to think I was > in CPANPLUS, so that's good. Now that I'm at work I can try running > both of the DBIx::Class tarballs (from CPAN and from the url above) > inside my chroot() area if you think that would be helpful. >
Please do let me know how things go, we want to make sure there are no more hickups before M::I is released.
Download (untitled) / with headers
text/plain 949b
On Tue May 12 11:38:17 2009, RIBASUSHI wrote: Show quoted text
> Please do let me know how things go, we want to make sure there are no > more hickups before M::I is released.
This still seems like a CPAN.pm bug to me. I resurrected the problematic chroot filesystem and restored it to the problem state and tried to install the CPAN version of DBIx::Class-0.8102 -- that fails to pull in the deps [see 0.0102-1.03.txt]. Then I pulled down the tar you linked to earlier, killed all my Digest::* modules so cpan would work with it, then I got the attached hand-downloaded.txt result; so I'd say you're good to go, but it still seems like a CPAN.pm thing to me. Even if M::I incorrectly thinks it's in CPANPLUS, it still issues the warnings, so I don't understand why this fixed it. Oh, I was under CPAN.pm v1.9304 in all cases. -- If riding in an airplane is flying, then riding in a boat is swimming. 107 jumps, 43.5 minutes of freefall, 83.4 freefall miles.
DBIx-Class-0.08102/META.yml CPAN: File::Temp loaded ok (v0.21) CPAN.pm: Going to build R/RI/RIBASUSHI/DBIx-Class-0.08102.tar.gz *** Module::AutoInstall version 1.03 *** Checking for Perl dependencies... *** Since we're running under CPAN, I'll just let it take care of the dependency's installation later. [Core Features] - Test::Builder ...loaded. (0.86 >= 0.33) - Test::Warn ...loaded. (0.11 >= 0.11) - Test::Exception ...loaded. (0.27) - Test::Deep ...loaded. (0.103) - DBD::SQLite ...missing. (would need 1.23) - Data::Page ...loaded. (2.00 >= 2) - Scalar::Util ...loaded. (1.19) - SQL::Abstract ...missing. (would need 1.54) - SQL::Abstract::Limit ...missing. (would need 0.13) - Class::C3::Componentised ...missing. (would need 1.0005) - Storable ...loaded. (2.18) - Carp::Clan ...loaded. (6.00) - DBI ...loaded. (1.607 >= 1.4) - Module::Find ...loaded. (0.06) - Class::Inspector ...loaded. (1.23) - Class::Accessor::Grouped ...missing. (would need 0.08003) - JSON::Any ...loaded. (1.17 >= 1.17) - Scope::Guard ...loaded. (0.03 >= 0.03) - Path::Class ...loaded. (0.16) - List::Util ...loaded. (1.19 >= 1.19) - Sub::Name ...loaded. (0.04 >= 0.04) - MRO::Compat ...loaded. (0.09 >= 0.09) *** Module::AutoInstall configuration finished. Checking if your kit is complete... Looks good Warning: prerequisite Class::Accessor::Grouped 0.08003 not found. We have 0.08001. Warning: prerequisite Class::C3::Componentised 1.0005 not found. We have 1.0003. Warning: prerequisite DBD::SQLite 1.23 not found. We have 1.14. Warning: prerequisite SQL::Abstract 1.54 not found. We have 1.24. Warning: prerequisite SQL::Abstract::Limit 0.13 not found. We have 0.12. Writing Makefile for DBIx::Class ---- Unsatisfied dependencies detected during ---- ---- RIBASUSHI/DBIx-Class-0.08102.tar.gz ---- DBD::SQLite [requires] SQL::Abstract [requires] SQL::Abstract::Limit [requires] Class::Accessor::Grouped [requires] Class::C3::Componentised [requires] Shall I follow them and prepend them to the queue of modules we are processing right now? [yes]
Download 0.08102-1.03.txt
text/plain 22.1k

Message body is not shown because it is too large.

Download (untitled) / with headers
text/plain 157b
DBIx::Class 0.08103 just released on CPAN fixes this RT. The reported problem should go away entirely, as this release uses a new version of Module::Install.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.