Skip Menu |
 

This queue is for tickets about the MooseX-Types-Structured CPAN distribution.

Report information
The Basics
Id: 45603
Status: resolved
Priority: 0/
Queue: MooseX-Types-Structured

People
Owner: Nobody in particular
Requestors: nelo.onyiah [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.13
Fixed in: (no value)



Subject: Broken compatibility with Moose v0.76
Download (untitled) / with headers
text/plain 634b
Hi, You may already be aware of this but it seems like the recent update of Moose has broken this module. The attached example illustrates the problem. It keeps warning about not "inlining" the constructor probably due to: around 'new' => sub { ... }; I am assuming (based on the warning) that the solution would be: __PACKAGE__->meta->make_immutable( inline_constructor => 0 ); This issue is preventing me from installing MooseX::Declare, which I believe is also one of your modules =) Also there does not appear to be a VERSION number and as such I cannot update the installed version of the module via CPANPLUS. Thanks.
Subject: t.pl
Download t.pl
text/x-perl 807b
#!/usr/bin/env perl use strict; use warnings; use MooseX::Types::Structured; print join( "\n", "-----------------", "STILL ALIVE", "-----------------", ), "\n"; =head1 OUTPUTS: Not inlining 'new' for MooseX::Meta::TypeCoercion::Structured since it is not inheriting the default Moose::Object::new If you are certain you don't need to inline your constructor, specify inline_constructor => 0 in your call to MooseX::Meta::TypeCoercion::Structured->meta->make_immutable Not inlining a constructor for MooseX::Meta::TypeConstraint::Structured since it defines its own constructor. If you are certain you don't need to inline your constructor, specify inline_constructor => 0 in your call to MooseX::Meta::TypeConstraint::Structured->meta->make_immutable ----------------- STILL ALIVE ----------------- =cut
Download (untitled) / with headers
text/plain 915b
Sorry, I forgot to supply my information: perl v5.010 Moose v0.76 MooseX::Declare v0.10 Linux bc-9-1-03 2.6.5--286tg3susesfs #1 SMP Mon Aug 20 14:43:24 BST 2007 x86_64 GNU/Linux On Thu Apr 30 12:44:16 2009, nelo.onyiah@gmail.com wrote: Show quoted text
> Hi, > > You may already be aware of this but it seems like the recent update of > Moose has broken this module. The attached example illustrates the > problem. It keeps warning about not "inlining" the constructor probably > due to: > > around 'new' => sub { ... }; > > I am assuming (based on the warning) that the solution would be: > > __PACKAGE__->meta->make_immutable( inline_constructor => 0 ); > > This issue is preventing me from installing MooseX::Declare, which I > believe is also one of your modules =) > > Also there does not appear to be a VERSION number and as such I cannot > update the installed version of the module via CPANPLUS. > > Thanks.
Download (untitled) / with headers
text/plain 1.2k
On Thu Apr 30 12:53:05 2009, nelo.onyiah@gmail.com wrote: Show quoted text
> Sorry, > > I forgot to supply my information: > > perl v5.010 > Moose v0.76 > MooseX::Declare v0.10 > Linux bc-9-1-03 2.6.5--286tg3susesfs #1 SMP Mon Aug 20 14:43:24 BST 2007 > x86_64 GNU/Linux > > On Thu Apr 30 12:44:16 2009, nelo.onyiah@gmail.com wrote:
> > Hi, > > > > You may already be aware of this but it seems like the recent update of > > Moose has broken this module. The attached example illustrates the > > problem. It keeps warning about not "inlining" the constructor probably > > due to: > > > > around 'new' => sub { ... }; > > > > I am assuming (based on the warning) that the solution would be: > > > > __PACKAGE__->meta->make_immutable( inline_constructor => 0 ); > > > > This issue is preventing me from installing MooseX::Declare, which I > > believe is also one of your modules =) > > > > Also there does not appear to be a VERSION number and as such I cannot > > update the installed version of the module via CPANPLUS. > > > > Thanks.
> >
Hmm, I thought rafl release a new version that has that code. looks like version 0.13 has the updates. Are you sure you are using version 0.13? I plan an update soon to get ride of the around new stuff, hopefully will solve lingering issues. Probably sometime next week.
Download (untitled) / with headers
text/plain 1.5k
Hi, It appears the changes have been updated. There is still no version number in the module so I had to install it via URL in CPANPLUS. But at least it now installs =) Thank you. On Thu Apr 30 13:45:27 2009, JJNAPIORK wrote: Show quoted text
> On Thu Apr 30 12:53:05 2009, nelo.onyiah@gmail.com wrote:
> > Sorry, > > > > I forgot to supply my information: > > > > perl v5.010 > > Moose v0.76 > > MooseX::Declare v0.10 > > Linux bc-9-1-03 2.6.5--286tg3susesfs #1 SMP Mon Aug 20 14:43:24 BST 2007 > > x86_64 GNU/Linux > > > > On Thu Apr 30 12:44:16 2009, nelo.onyiah@gmail.com wrote:
> > > Hi, > > > > > > You may already be aware of this but it seems like the recent
update of Show quoted text
> > > Moose has broken this module. The attached example illustrates the > > > problem. It keeps warning about not "inlining" the constructor
probably Show quoted text
> > > due to: > > > > > > around 'new' => sub { ... }; > > > > > > I am assuming (based on the warning) that the solution would be: > > > > > > __PACKAGE__->meta->make_immutable( inline_constructor => 0 ); > > > > > > This issue is preventing me from installing MooseX::Declare, which I > > > believe is also one of your modules =) > > > > > > Also there does not appear to be a VERSION number and as such I cannot > > > update the installed version of the module via CPANPLUS. > > > > > > Thanks.
> > > >
> > > Hmm, I thought rafl release a new version that has that code. looks > like version 0.13 has the updates. Are you sure you are using version
0.13? Show quoted text
> > I plan an update soon to get ride of the around new stuff, hopefully > will solve lingering issues. Probably sometime next week. > >


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.