This queue is for tickets about the NEXT CPAN distribution.

Report information
The Basics
Id:
44921
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
jdhedden [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Critical
Broken in:
  • 0.51
  • 0.52
  • 0.60
  • 0.61
  • 0.62
Fixed in:
(no value)



Subject: [PATCH] Install NEXT.pm in correct dir
NEXT.pm has been in core since 5.7.3. However, the CPAN version is defaulting to install under site_perl, and is therefore masked by the older core version. The attached patch corrects this.
Subject: NEXT.patch
--- NEXT-0.62/Makefile.PL.orig 2009-04-10 09:20:58.916625000 -0400 +++ NEXT-0.62/Makefile.PL 2009-04-10 09:22:17.229125000 -0400 @@ -3,4 +3,5 @@ WriteMakefile( NAME => q[NEXT], VERSION_FROM => q[lib/NEXT.pm], + INSTALLDIRS => $] >= 5.007003 ? 'perl' : 'site', );


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.