This queue is for tickets about the XML-LibXSLT CPAN distribution.

Report information
The Basics
Id:
44865
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
ddascalescu+perl [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
(no value)
Fixed in:
(no value)



Subject: Easy fix: please mention which libraries are required
I've tried to install XML::LibXSLT as part of MojoMojo, and it died with various error messages which may be a tad too cryptic for a user who just needs the module as a dependency: /usr/bin/ld: cannot find -lgcrypt /usr/bin/ld: cannot find -lgdbm I had to go online and find out what these executables are part of. To save future users that time, the POD could mention the required libraries, which as far as I can tell are: libxslt-dev, libgcrypt11-dev (for `lgcrypt`), libgdbm3-dev (for `lgdbm`) and possibly libxml2-dev. HTH, Dan
Hi, the correct dependencies should be determined by pkg-config or xslt-config. Explicit dependencies on other libraries have been removed in the SVN version. The README mentiones briefly the dependencies and how to obtain them. Closing this ticket, thanks, -- Petr Dne st 08.dub.2009 05:32:59, dandv napsal(a):
Show quoted text
> I've tried to install XML::LibXSLT as part of MojoMojo, and it died with > various error messages which may be a tad too cryptic for a user who > just needs the module as a dependency: > > /usr/bin/ld: cannot find -lgcrypt > /usr/bin/ld: cannot find -lgdbm > > I had to go online and find out what these executables are part of. To > save future users that time, the POD could mention the required > libraries, which as far as I can tell are: libxslt-dev, libgcrypt11-dev > (for `lgcrypt`), libgdbm3-dev (for `lgdbm`) and possibly libxml2-dev. > > HTH, > Dan


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.