Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the PPI CPAN distribution.

Report information
The Basics
Id: 44014
Status: resolved
Priority: 0/
Queue: PPI

People
Owner: Nobody in particular
Requestors: ANIRVAN [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.202_03
Fixed in: (no value)



Subject: PPI accidentally stopped working with Perl 5.6
Download (untitled) / with headers
text/plain 925b
Jumping from release 1.202_01 to 1.202_03, something happened in the code that caused PPI to stop working on Perl 5.6. I presume this isn't intentional, since the Changes file from 1.202_03 states "Upgrading explicit Perl dependency to 5.006" Because PPI is broken, projects that make use of current version of PPI (e.g. Perl::Critic also fail on the Perl 5.6 platform). You can see the difference on the Testers Matrix: http://bbbike.radzeit.de/~slaven/cpantestersmatrix.cgi?dist=PPI%201.202_01 http://bbbike.radzeit.de/~slaven/cpantestersmatrix.cgi?dist=PPI%201.202_03 Here are example test failure reports: http://www.nntp.perl.org/group/perl.cpan.testers/2008/05/msg1452822.html http://www.nntp.perl.org/group/perl.cpan.testers/2008/11/msg2577062.html http://www.nntp.perl.org/group/perl.cpan.testers/2008/11/msg2578102.html If needed, I'd be happy to help you in testing possible solutions under Perl 5.6. Thank you.
Subject: Re: [rt.cpan.org #44014] PPI accidentally stopped working with Perl 5.6
Date: Wed, 11 Mar 2009 12:34:17 +1100
To: bug-PPI [...] rt.cpan.org
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
Download (untitled) / with headers
text/plain 1.5k
Unfortunately, I don't have convenient access to a 5.6 install to see why this is the case... I'll see if I can work out some form of access. Adam K 2009/3/11 Anirvan Chatterjee via RT <bug-PPI@rt.cpan.org>: Show quoted text
> Tue Mar 10 15:58:58 2009: Request 44014 was acted upon. > Transaction: Ticket created by ANIRVAN >       Queue: PPI >     Subject: PPI accidentally stopped working with Perl 5.6 >   Broken in: 1.202_03 >    Severity: Normal >       Owner: Nobody >  Requestors: ANIRVAN@cpan.org >      Status: new >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=44014 > > > > Jumping from release 1.202_01 to 1.202_03, something happened in the > code that caused PPI to stop working on Perl 5.6. I presume this isn't > intentional, since the Changes file from 1.202_03 states "Upgrading > explicit Perl dependency to 5.006" > > Because PPI is broken, projects that make use of current version of PPI > (e.g. Perl::Critic also fail on the Perl 5.6 platform). > > You can see the difference on the Testers Matrix: > http://bbbike.radzeit.de/~slaven/cpantestersmatrix.cgi?dist=PPI%201.202_01 > http://bbbike.radzeit.de/~slaven/cpantestersmatrix.cgi?dist=PPI%201.202_03 > > Here are example test failure reports: > http://www.nntp.perl.org/group/perl.cpan.testers/2008/05/msg1452822.html > http://www.nntp.perl.org/group/perl.cpan.testers/2008/11/msg2577062.html > http://www.nntp.perl.org/group/perl.cpan.testers/2008/11/msg2578102.html > > If needed, I'd be happy to help you in testing possible solutions under > Perl 5.6. Thank you. >
Minimum version of Perl moved to 5.6, and is now tested.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.