Skip Menu |
 

This queue is for tickets about the DJabberd CPAN distribution.

Report information
The Basics
Id: 44001
Status: new
Priority: 0/
Queue: DJabberd

People
Owner: Nobody in particular
Requestors: atistler [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Vhost using stream "to" attribute
Date: Tue, 10 Mar 2009 09:24:49 -0400
To: bug-DJabberd [...] rt.cpan.org
From: Adam Tistler <atistler [...] gmail.com>
Download (untitled) / with headers
text/plain 1.1k
Hello, I am not sure if this is a djabberd bug or an adium/proteus bug. I am tending to think that this is a adium/proteus bug in which case I apologize for bothering you. Regardless of what I set Host Name to be when setting up my jabber client, the to= attribute will be jabber.org. This does not seem correct to me as it should be host name of the jabber server that I am connecting to. Djabberd interprets the to= attribute as the vhost, and therefore cannot find the vhost. SEND: <stream:stream SEND: to='jabber.org' SEND: xmlns='jabber:client' SEND: xmlns:stream='http://etherx.jabber.org/streams'> The attributes of the stream element are as follows: o to -- The 'to' attribute SHOULD be used only in the XML stream header from the initiating entity to the receiving entity, and MUST be set to a hostname serviced by the receiving entity. There SHOULD NOT be a 'to' attribute set in the XML stream header by which the receiving entity replies to the initiating entity; however, if a 'to' attribute is included, it SHOULD be silently ignored by the initiating entity.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.