Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 44000
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: MTHURN [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.79
Fixed in: 0.80



Subject: perl version check fails
Download (untitled) / with headers
text/plain 262b
I do not have any perl version requirement in my Makefile.PL, but I get the following error when my bundle is attempted to install with CPANPLUS: ERROR: perl: Version 5.008009 is installed, but we need version >= 5.8 at inc/Module/Install/Makefile.pm line 172.
Subject: Re: [rt.cpan.org #44000] perl version check fails
Date: Wed, 11 Mar 2009 12:33:22 +1100
To: bug-Module-Install [...] rt.cpan.org
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
Download (untitled) / with headers
text/plain 940b
I'd need to see the entire distribution, but if you are using all_from, it will pick up the contents of a "use 5.8" statement inside your .pm module. As a workaround, change that to use 5.008. I'll look into the problem. Adam K 2009/3/11 Martin Thurn via RT <bug-Module-Install@rt.cpan.org>: Show quoted text
> Tue Mar 10 09:01:31 2009: Request 44000 was acted upon. > Transaction: Ticket created by MTHURN >       Queue: Module-Install >     Subject: perl version check fails >   Broken in: 0.79 >    Severity: Normal >       Owner: Nobody >  Requestors: MTHURN@cpan.org >      Status: new >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=44000 > > > > I do not have any perl version requirement in my Makefile.PL, but I get > the following error when my bundle is attempted to install with CPANPLUS: > > ERROR: perl: Version 5.008009 is installed, but we need version >= 5.8 > at inc/Module/Install/Makefile.pm line 172. > >
RT-Send-CC: martin.thurn [...] ngc.com
Download (untitled) / with headers
text/plain 524b
On Tue Mar 10 21:33:36 2009, adamkennedybackup@gmail.com wrote: Show quoted text
> I'd need to see the entire distribution, but if you are using > all_from, it will pick up the contents of a "use 5.8" statement inside > your .pm module.
Yes, sorry, my module DOES have "use 5.8", I forgot about that when I made this report. Also, I can not reproduce the problem now, so I think there must have been an old version of M::I bundled in there. I guess I really *should* do `make disttest` every time 8-) -- - - Martin 'Kingpin' Thurn
Subject: Re: [rt.cpan.org #44000] perl version check fails
Date: Fri, 13 Mar 2009 17:28:33 +1100
To: bug-Module-Install [...] rt.cpan.org
From: Adam Kennedy <adamkennedybackup [...] gmail.com>
Download (untitled) / with headers
text/plain 881b
An upcoming version of M:I will also be testing that you have the latest version (when I get around to it) to that would hopefully also help fix the problem. Adam K 2009/3/13 Martin Thurn via RT <bug-Module-Install@rt.cpan.org>: Show quoted text
>       Queue: Module-Install >  Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=44000 > > > On Tue Mar 10 21:33:36 2009, adamkennedybackup@gmail.com wrote:
>> I'd need to see the entire distribution, but if you are using >> all_from, it will pick up the contents of a "use 5.8" statement inside >> your .pm module.
> >  Yes, sorry, my module DOES have "use 5.8", I forgot about that when I > made this report. >  Also, I can not reproduce the problem now, so I think there must have > been an old version of M::I bundled in there.  I guess I really *should* > do `make disttest` every time 8-) > > -- >  - - Martin 'Kingpin' Thurn >
Closed this ticket as this is fixed in 0.80. Thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.