This queue is for tickets about the XML-LibXSLT CPAN distribution.

Report information
The Basics
Id:
43606
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
htoug [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.94
Fixed in:
(no value)



Subject: -lgcrypt -lgpg-error should not be required
Building on a machine without any gnome-tools - particularly not pkg-config - the Makefile.PL inserts ' -lgcrypt -lgpg-error' as libs in $exslt_defaults. This is harmful if the installation does not have libgcrypt or libpg-error installed - as is the case on out RHEL5 server. The two libs were added due to bug #25525. Trying to discover which lib are necccesary is hard - very hard. But this solution is IMHO not optimal. Our workaround was to patch Makefile.PL...
I have removed these defaults in the SVN versions, we'll see what new reports it will bring. Anyway, pkg-config for libexslt is consulted so if there is a dependency on these libraries and the system provides pkg-config files, the Makefile.PL should be able to find out. -- Petr Dne st 25.úno.2009 09:04:32, HTOUG napsal(a):
Show quoted text
> Building on a machine without any gnome-tools - particularly not > pkg-config - the Makefile.PL inserts ' -lgcrypt -lgpg-error' as libs in > $exslt_defaults. > > This is harmful if the installation does not have libgcrypt or > libpg-error installed - as is the case on out RHEL5 server. > > The two libs were added due to bug #25525. > > Trying to discover which lib are necccesary is hard - very hard. But > this solution is IMHO not optimal. > > Our workaround was to patch Makefile.PL...


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.