Skip Menu |
 

This queue is for tickets about the Math-GSL CPAN distribution.

Report information
The Basics
Id: 43569
Status: resolved
Priority: 0/
Queue: Math-GSL

People
Owner: jonathan [...] leto.net
Requestors: heriche [...] embl.de
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Math::GSL fails to install
Date: Tue, 24 Feb 2009 09:54:13 +0100
To: bug-Math-Gsl [...] rt.cpan.org
From: Jean-Karim Heriche <heriche [...] embl.de>
Download (untitled) / with headers
text/plain 918b
Hi, Math-GSL-0.16 fails to install. The problem occurs here: gcc -I/usr/lib/perl/5.8/CORE -c -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBIAN -fno-strict-aliasing -pipe -I/usr/local/include -Wno-strict-aliasing -Wno-unused-function -Wno-unused-value -Wno-unused-function -Wno-unused-variable -o xs/Poly_wrap.o xs/Poly_wrap.c xs/Poly_wrap.c: In function ‘_wrap_gsl_poly_complex_eval’: xs/Poly_wrap.c:2516: error: incompatible types in assignment xs/Poly_wrap.c: In function ‘_wrap_gsl_complex_poly_complex_eval’: xs/Poly_wrap.c:2626: error: incompatible types in assignment error building .o file from 'xs/Poly_wrap.c' at inc/GSLBuilder.pm line 182. I am using perl 5.8.8 and gcc 4.2.4 on i686 GNU/Linux (Ubuntu). Thanks for doing a great job making GSL available to perl users. J-K -- Dr Jean-Karim Hériché EMBL Heidelberg Meyerhofstraße 1 69117 Heidelberg Germany Tel: +49 [0] 6221 387 8857
Download (untitled) / with headers
text/plain 1.1k
Hello, Which version of GSL are you using? You can find that out with: gsl-config --version I imagine it is 1.10, which is known to not like Math::GSL. If it is possible for you to upgrade to GSL 1.12 I am pretty sure that will solve your problems *and* you will get about 2 years worth of GSL features and bugfixes! Cheers, Jonathan Leto Show quoted text
> Math-GSL-0.16 fails to install. The problem occurs here: > gcc -I/usr/lib/perl/5.8/CORE -c -D_REENTRANT -D_GNU_SOURCE > -DTHREADS_HAVE_PIDS -DDEBIAN -fno-strict-aliasing -pipe > -I/usr/local/include -Wno-strict-aliasing -Wno-unused-function > -Wno-unused-value -Wno-unused-function -Wno-unused-variable -o > xs/Poly_wrap.o xs/Poly_wrap.c > xs/Poly_wrap.c: In function ‘_wrap_gsl_poly_complex_eval’: > xs/Poly_wrap.c:2516: error: incompatible types in assignment > xs/Poly_wrap.c: In function ‘_wrap_gsl_complex_poly_complex_eval’: > xs/Poly_wrap.c:2626: error: incompatible types in assignment > error building .o file from 'xs/Poly_wrap.c' at inc/GSLBuilder.pm line > 182. > > I am using perl 5.8.8 and gcc 4.2.4 on i686 GNU/Linux (Ubuntu). > > Thanks for doing a great job making GSL available to perl users. > > J-K >
Subject: Re: [rt.cpan.org #43569] Math::GSL fails to install
Date: Fri, 27 Mar 2009 08:40:05 +0100
To: bug-Math-Gsl [...] rt.cpan.org
From: Jean-Karim Heriche <heriche [...] embl.de>
Download (untitled) / with headers
text/plain 1.5k
Hi, Thanks for getting back to me. I am using GSL 1.12. I gave up on Math-GSL-0.16 but I just found that Math-GSL-0.18 installs without problem. Again many thanks. J-K On Thu, 2009-03-26 at 23:15 -0400, Jonathan Leto via RT wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=43569 > > > Hello, > > Which version of GSL are you using? You can find that out with: > > gsl-config --version > > I imagine it is 1.10, which is known to not like Math::GSL. If it is > possible for you to upgrade to GSL 1.12 I am pretty sure that will solve > your problems *and* you will get about 2 years worth of GSL features and > bugfixes! > > Cheers, > > Jonathan Leto >
> > Math-GSL-0.16 fails to install. The problem occurs here: > > gcc -I/usr/lib/perl/5.8/CORE -c -D_REENTRANT -D_GNU_SOURCE > > -DTHREADS_HAVE_PIDS -DDEBIAN -fno-strict-aliasing -pipe > > -I/usr/local/include -Wno-strict-aliasing -Wno-unused-function > > -Wno-unused-value -Wno-unused-function -Wno-unused-variable -o > > xs/Poly_wrap.o xs/Poly_wrap.c > > xs/Poly_wrap.c: In function ‘_wrap_gsl_poly_complex_eval’: > > xs/Poly_wrap.c:2516: error: incompatible types in assignment > > xs/Poly_wrap.c: In function ‘_wrap_gsl_complex_poly_complex_eval’: > > xs/Poly_wrap.c:2626: error: incompatible types in assignment > > error building .o file from 'xs/Poly_wrap.c' at inc/GSLBuilder.pm line > > 182. > > > > I am using perl 5.8.8 and gcc 4.2.4 on i686 GNU/Linux (Ubuntu). > > > > Thanks for doing a great job making GSL available to perl users. > > > > J-K > >
> > > >
Issue resolved itself in 0.18 .


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.