Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CGI-Application-Server CPAN distribution.

Report information
The Basics
Id: 43338
Status: stalled
Priority: 0/
Queue: CGI-Application-Server

People
Owner: Nobody in particular
Requestors: OLEGM [...] cpan.org
Cc: leonard [...] umn.edu
AdminCc:

Bug Information
Severity: (no value)
Broken in: 0.061
Fixed in: (no value)



CC: leonard [...] umn.edu
Subject: Failing tests on strawberry perl for windows
Download (untitled) / with headers
text/plain 3.1k
Trying to install on a Windows XP box with strawberry perl v5.10.0 built for MSWin32-x86-multi-thread It seems that some of the tests are failing. I am available to help resolve this bug, and I am on the CGI::Application mailing list and irc channel. Show quoted text
cpan> install Test::HTTP::Server::Simple
Running install for module 'Test::HTTP::Server::Simple' Running make for J/JE/JESSE/Test-HTTP-Server-Simple-0.09.tar.gz Has already been unwrapped into directory C:\strawberry\cpan\build\Test-HTTP-S erver-Simple-0.09-T4HRfd Has already been made Running make test C:\strawberry\perl\bin\perl.exe "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib\lib', 'blib\arch')" t/*.t t/00.load...........# Testing Test::HTTP::Server::Simple 0.09 t/00.load...........ok t/01.basic..........ok t/pod-coverage......ok t/pod...............ok All tests successful. Files=4, Tests=9, 4 wallclock secs ( 0.08 usr + 0.00 sys = 0.08 CPU) Result: PASS JESSE/Test-HTTP-Server-Simple-0.09.tar.gz C:\strawberry\c\bin\dmake.EXE test -- OK Running make install Prepending C:\strawberry\cpan\build\Test-HTTP-Server-Simple-0.09-T4HRfd/blib/arc h C:\strawberry\cpan\build\Test-HTTP-Server-Simple-0.09-T4HRfd/blib/lib to PERL5 LIB for 'install' Installing C:\strawberry\perl\site\lib\Test\HTTP\Server\Simple.pm Writing C:\strawberry\perl\site\lib\auto\Test\HTTP\Server\Simple\.packlist Appending installation info to C:\strawberry\perl\lib/perllocal.pod JESSE/Test-HTTP-Server-Simple-0.09.tar.gz C:\strawberry\c\bin\dmake.EXE install UNINST=1 -- OK Show quoted text
cpan> install CGI::Application::Server
Running install for module 'CGI::Application::Server' Running Build for R/RJ/RJBS/CGI-Application-Server-0.061.tar.gz Has already been unwrapped into directory C:\strawberry\cpan\build\CGI-Applica tion-Server-0.061-E7o4aZ Has already been made Running Build test t/000_load...........................ok t/001_basic..........................ok t/002_valid_entry_points.............ok t/003_dispatch.......................ok t/004_object_as_entry_point..........ok t/005_mode_param_from_path_info......ok t/006_replacequeryobject.............2/5 # Failed test '... got bar with CGI::Application object' # at t/006_replacequeryobject.t line 36. # got: "foo" # length: 3 # expected: "bar" # length: 3 # strings begin to differ at char 1 # Looks like you failed 1 test of 5. t/006_replacequeryobject............. Dubious, test returned 1 (wstat 256, 0x100 ) Failed 1/5 subtests t/pod................................ok t/pod_coverage.......................ok Test Summary Report ------------------- t/006_replacequeryobject.t (Wstat: 256 Tests: 5 Failed: 1) Failed test number(s): 3 Non-zero exit status: 1 Files=9, Tests=93, 12 wallclock secs ( 0.13 usr + 0.09 sys = 0.22 CPU) Result: FAIL Failed 1/9 test programs. 1/93 subtests failed. RJBS/CGI-Application-Server-0.061.tar.gz C:\strawberry\perl\bin\perl.exe ./Build test -- NOT OK //hint// to see the cpan-testers results for installing this module, try: reports RJBS/CGI-Application-Server-0.061.tar.gz Running Build install make test had returned bad status, won't install without force Failed during this command: RJBS/CGI-Application-Server-0.061.tar.gz : make_test NO Show quoted text
cpan>
Patches welcome, but I don't think this is something I'll get to soon. -- rjbs


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.