Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Alien-SVN CPAN distribution.

Report information
The Basics
Id: 42970
Status: open
Priority: 0/
Queue: Alien-SVN

People
Owner: Nobody in particular
Requestors: sdebroise.ext [...] orange-ftgroup.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Problem installing Alien SVN module
Date: Mon, 2 Feb 2009 15:38:06 +0100
To: <bug-alien-SVN [...] rt.cpan.org>
From: <sdebroise.ext [...] orange-ftgroup.com>
Download (untitled) / with headers
text/plain 1.7k
I am trying to install the Alien SVN module without success (see Show quoted text
> below). I am using an Intel Mac (Mac OS X 10.4.11) with subversion
1.5.5 Running make cd subversion/libsvn_subr && /bin/sh /Users/andremotte/Desktop/Alien-SVN-1.4.6.0_2/src/subversion/libtool --tag=CC --silent --mode=link gcc -g -O2 -L/opt/subversion/lib -rpath /usr/local/lib/perl5/site_perl/5.10.0/darwin-2level/Alien/SVN --prefix=/usr/local -o libsvn_subr-1.la auth.lo cmdline.lo compat.lo config.lo config_auth.lo config_file.lo config_win.lo constructors.lo ctype.lo date.lo dso.lo error.lo hash.lo io.lo kitchensink.lo lock.lo md5.lo nls.lo opt.lo path.lo pool.lo prompt.lo quoprint.lo simple_providers.lo sorts.lo ssl_client_cert_providers.lo ssl_client_cert_pw_providers.lo ssl_server_trust_providers.lo stream.lo subst.lo svn_base64.lo svn_string.lo target.lo time.lo user.lo username_providers.lo utf.lo utf_validate.lo validate.lo version.lo xml.lo -L/opt/subversion/lib -R/opt/subversion/lib -laprutil-1 -ldb-4.5 -lexpat -liconv -L/opt/subversion/lib -R/opt/subversion/lib -lapr-1 -lpthread -framework Security -framework CoreFoundation -framework CoreServices -lz /usr/bin/libtool: for architecture ppc64 object: /opt/subversion/lib/libaprutil-1.dylib malformed object (unknown load command 7) /usr/bin/libtool: for architecture ppc64 object: /opt/subversion/lib/libdb-4.5.dylib malformed object (unknown load command 7) /usr/bin/libtool: for architecture ppc64 object: /opt/subversion/lib/libexpat.dylib malformed object (unknown load command 7) /usr/bin/libtool: for architecture ppc64 object: /opt/subversion/lib/libapr-1.dylib malformed object (unknown load command 7) make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1 building subversion failed at inc/My/SVN/Builder.pm line 121.
Download (untitled) / with headers
text/plain 2.4k
On Mon Feb 02 12:38:40 2009, sdebroise.ext@orange-ftgroup.com wrote: Show quoted text
> I am trying to install the Alien SVN module without success (see
> > below). I am using an Intel Mac (Mac OS X 10.4.11) with subversion
> 1.5.5 > > Running make > cd subversion/libsvn_subr && /bin/sh > /Users/andremotte/Desktop/Alien-SVN-1.4.6.0_2/src/subversion/libtool > --tag=CC --silent --mode=link gcc -g -O2 -L/opt/subversion/lib > -rpath /usr/local/lib/perl5/site_perl/5.10.0/darwin-2level/Alien/SVN > --prefix=/usr/local -o libsvn_subr-1.la auth.lo cmdline.lo compat.lo > config.lo config_auth.lo config_file.lo config_win.lo constructors.lo > ctype.lo date.lo dso.lo error.lo hash.lo io.lo kitchensink.lo lock.lo > md5.lo nls.lo opt.lo path.lo pool.lo prompt.lo quoprint.lo > simple_providers.lo sorts.lo ssl_client_cert_providers.lo > ssl_client_cert_pw_providers.lo ssl_server_trust_providers.lo stream.lo > subst.lo svn_base64.lo svn_string.lo target.lo time.lo user.lo > username_providers.lo utf.lo utf_validate.lo validate.lo version.lo > xml.lo -L/opt/subversion/lib -R/opt/subversion/lib -laprutil-1 -ldb-4.5 > -lexpat -liconv -L/opt/subversion/lib -R/opt/subversion/lib -lapr-1 > -lpthread -framework Security -framework CoreFoundation -framework > CoreServices -lz > > /usr/bin/libtool: for architecture ppc64 object: > /opt/subversion/lib/libaprutil-1.dylib malformed object (unknown load > command 7) > /usr/bin/libtool: for architecture ppc64 object: > /opt/subversion/lib/libdb-4.5.dylib malformed object (unknown load > command 7) > /usr/bin/libtool: for architecture ppc64 object: > /opt/subversion/lib/libexpat.dylib malformed object (unknown load > command 7) > /usr/bin/libtool: for architecture ppc64 object: > /opt/subversion/lib/libapr-1.dylib malformed object (unknown load > command 7) > make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1 > building subversion failed at inc/My/SVN/Builder.pm line 121.
Seeing "/usr/bin/libtool: for architecture ppc64 object" suggests that something tried to build as PowerPC and not Intel. Did you upgrade from a PowerPC mac to an Intel mac at some point? Also that it's referring to /opt/subversion/lib suggests that you have another version of subversion installed, one compiled for PowerPC. Alien::SVN should not be tripped up by having another copy of Subversion installed, but unfortunately it is. In order to find out if this is an Alien::SVN issue or a Subversion issue, could you go into src/subversion/ and try to build Subversion by hand?
From: zacharysyoung [...] gmail.com
On Sun Feb 08 17:41:40 2009, MSCHWERN wrote: Show quoted text
> On Mon Feb 02 12:38:40 2009, sdebroise.ext@orange-ftgroup.com wrote:
> > I am trying to install the Alien SVN module without success (see
> > > below). I am using an Intel Mac (Mac OS X 10.4.11) with subversion
> > 1.5.5 > > > > Running make > > cd subversion/libsvn_subr && /bin/sh > > /Users/andremotte/Desktop/Alien-SVN-1.4.6.0_2/src/subversion/libtool > > --tag=CC --silent --mode=link gcc -g -O2 -L/opt/subversion/lib > > -rpath /usr/local/lib/perl5/site_perl/5.10.0/darwin-2level/Alien/SVN > > --prefix=/usr/local -o libsvn_subr-1.la auth.lo cmdline.lo compat.lo > > config.lo config_auth.lo config_file.lo config_win.lo constructors.lo > > ctype.lo date.lo dso.lo error.lo hash.lo io.lo kitchensink.lo lock.lo > > md5.lo nls.lo opt.lo path.lo pool.lo prompt.lo quoprint.lo > > simple_providers.lo sorts.lo ssl_client_cert_providers.lo > > ssl_client_cert_pw_providers.lo ssl_server_trust_providers.lo stream.lo > > subst.lo svn_base64.lo svn_string.lo target.lo time.lo user.lo > > username_providers.lo utf.lo utf_validate.lo validate.lo version.lo > > xml.lo -L/opt/subversion/lib -R/opt/subversion/lib -laprutil-1 -ldb-4.5 > > -lexpat -liconv -L/opt/subversion/lib -R/opt/subversion/lib -lapr-1 > > -lpthread -framework Security -framework CoreFoundation -framework > > CoreServices -lz > > > > /usr/bin/libtool: for architecture ppc64 object: > > /opt/subversion/lib/libaprutil-1.dylib malformed object (unknown load > > command 7) > > /usr/bin/libtool: for architecture ppc64 object: > > /opt/subversion/lib/libdb-4.5.dylib malformed object (unknown load > > command 7) > > /usr/bin/libtool: for architecture ppc64 object: > > /opt/subversion/lib/libexpat.dylib malformed object (unknown load > > command 7) > > /usr/bin/libtool: for architecture ppc64 object: > > /opt/subversion/lib/libapr-1.dylib malformed object (unknown load > > command 7) > > make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1 > > building subversion failed at inc/My/SVN/Builder.pm line 121.
> > Seeing "/usr/bin/libtool: for architecture ppc64 object" suggests that > something tried to build as PowerPC and not Intel. Did you upgrade from > a PowerPC mac to an Intel mac at some point? > > Also that it's referring to /opt/subversion/lib suggests that you have > another version of subversion installed, one compiled for PowerPC. > Alien::SVN should not be tripped up by having another copy of Subversion > installed, but unfortunately it is. > > In order to find out if this is an Alien::SVN issue or a Subversion > issue, could you go into src/subversion/ and try to build Subversion by > hand?
I am having problems, well understanding the relationship between SVN-Alien and SVN-Core, and also in installing SVN-Core. I downloaded the tarball, 1. Unpacked it 2. Ran Build.PL, and it configured the SVN build 3. Ran Build, and to the best of my knowledge did not see any errors: /usr/local/lib64/perl5/Alien/SVN was created and running a simple test, `perl -e "use Alien::SVN;"' worked 4. Tried a simple test script with a "use SVN::Core", `perl test.pl' but it failed: "Can't locate SVN/Core.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at test.pl line 1. BEGIN failed--compilation aborted at test.pl line 1." 5. Navigated to src/subversion/subversion/bindings/swig/perl/native/ and ran `make install' 6. Tried `perl test.pl' again, and it failed, but with a different error: "Can't load '/usr/local/lib64/perl5/auto/SVN/_Core/_Core.so' for module SVN::_Core: libsvn_swig_perl-1.so.0: cannot open shared object file: No such file or directory at /usr/lib64/perl5/DynaLoader.pm line 200. at /usr/local/lib64/perl5/SVN/Base.pm line 59 BEGIN failed--compilation aborted at /usr/local/lib64/perl5/SVN/Core.pm line 5. Compilation failed in require at test.pl line 2. BEGIN failed--compilation aborted at test.pl line 2." I'm not a Perl admin/user by any stretch, just trying to get an extension for Bugzilla working. Any help will be greatly appreciated. Thank you, Zach


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.