Skip Menu |
 

This queue is for tickets about the MIME-tools CPAN distribution.

Report information
The Basics
Id: 42857
Status: resolved
Priority: 0/
Queue: MIME-tools

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: 5.427
Fixed in: (no value)



Subject: please provide a comment on PREREQ_PM version dependencies
Download (untitled) / with headers
text/plain 623b
(severity: wishlist, low, low, low priority) Yesterday I went through MIME-tools releases to find out how the File::Temp prerequisite developed. Why? Because current release requires File::Temp 0.18. I cannot easily install that because I'm in a bondage&discipline installation that has perl 5.8.8 and that came with File::Temp 0.16. In such a situation it would help a lot to find a comment in the Makefile.PL why the critical prerequisite version was increased. Please consider to keep required prereq versions low and to provide a comment when it is unavoidable. Thank you very much for the consideration:) Regards,
Subject: Re: [rt.cpan.org #42857] please provide a comment on PREREQ_PM version dependencies
Date: Wed, 28 Jan 2009 08:46:25 -0500
To: Andreas Koenig via RT <bug-MIME-tools [...] rt.cpan.org>
From: "Dave O'Neill" <dmo [...] dmo.ca>
Download (untitled) / with headers
text/plain 726b
On Wed, Jan 28, 2009 at 06:37:39AM -0500, Andreas Koenig via RT wrote: Show quoted text
> Yesterday I went through MIME-tools releases to find out how the > File::Temp prerequisite developed. Why? Because current release requires > File::Temp 0.18. I cannot easily install that because I'm in a > bondage&discipline installation that has perl 5.8.8 and that came with > File::Temp 0.16. > > In such a situation it would help a lot to find a comment in the > Makefile.PL why the critical prerequisite version was increased.
Actually, the appropriate place for that sort of comment is in the ChangeLog file -- which is actually where you'll find it: * (bugfix) require File::Temp 0.18 or newer, as we need seek() (RT#31032) Cheers, Dave
Of course! I had a blind spot there. Thanks!
Download (untitled) / with headers
text/plain 128b
No problem... the ChangeLog for MIME-tools was awful at one point, so I can't blame you for not looking this time. Cheers, Dave


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.