Skip Menu |
 

This queue is for tickets about the XML-RSS CPAN distribution.

Report information
The Basics
Id: 42700
Status: rejected
Priority: 0/
Queue: XML-RSS

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.43
Fixed in: (no value)



Subject: Dependency on 5.006 in Build.PL but not in Makefile.PL
Download (untitled) / with headers
text/plain 204b
As the subject says. On cpantesters I see all tests pass except those with 5.6.2 using the Makefile.PL See the cpantesters wiki for suggestions http://wiki.cpantesters.org/wiki/CPANAuthorNotes Regards,
Download (untitled) / with headers
text/plain 660b
On Thu Jan 22 23:46:35 2009, ANDK wrote: Show quoted text
> As the subject says. On cpantesters I see all tests pass except those > with 5.6.2 using the Makefile.PL
Well, this is the first line in Makefile.PL: {{{{{{{{{{{ use 5.006; }}}}}}}}}}} This is as indicated here: http://wiki.cpantesters.org/wiki/CPANAuthorNotes In any case, how will adding a requirement for 5.6.x (which already exists) prevent failures on 5.6.2? I don't understand. It seems the failures are caused by an XML::Parser bug which has a quirky reproduction. Regards, -- Shlomi Fish Show quoted text
> > See the cpantesters wiki for suggestions > http://wiki.cpantesters.org/wiki/CPANAuthorNotes > > Regards,
If I'd got my own mail I'd conclude the guy suggest to 'use 5.008'.
Download (untitled) / with headers
text/plain 278b
On Fri Jan 23 16:11:15 2009, ANDK wrote: Show quoted text
> If I'd got my own mail I'd conclude the guy suggest to 'use 5.008'.
Well, it's not an option. It's a bug in XML-Parser - not in XML-RSS, and I'd still like to support perl-5.6.2. So I'm going to close this bug. Regards, Shlomi Fish
This is a bug in XML-Parser and 5.6.2 - not in XML-RSS.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.