Skip Menu |
 

This queue is for tickets about the JavaScript CPAN distribution.

Report information
The Basics
Id: 42653
Status: resolved
Priority: 0/
Queue: JavaScript

People
Owner: Nobody in particular
Requestors: daphone [...] legitimatesounding.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.08
Fixed in: (no value)



Subject: crash
Download (untitled) / with headers
text/plain 470b
on 130th instance of javascript: Failed to create runtime at /usr/lib/perl5/JavaScript/Runtime.pm line 30. ubuntu 8.10, installed via apt-get install libjavascript-perl quick way to reproduce: #!/usr/bin/perl use Benchmark; use JavaScript; my $i = 1; timethese(150, { 'failure' => sub { print $i . "\n"; $i++; my $rt = JavaScript::Runtime->new(); my $cx = $rt->create_context(); $cx->eval("var i = 0;"); } });
Subject: Re: [rt.cpan.org #42653] crash
Date: Thu, 22 Jan 2009 09:14:58 +0100
To: bug-JavaScript [...] rt.cpan.org
From: Claes Jakobsson <claes [...] versed.se>
Hi, what version of JavaScript.pm does ubuntu package and what version of SpiderMonkey does it link against? your testscript works fine on OS X using SM 1.7 and JavaScript.pm 1.11 /claes On 22 jan 2009, at 05.46, jerry via RT wrote: Show quoted text
> Wed Jan 21 23:46:04 2009: Request 42653 was acted upon. > Transaction: Ticket created by jerrysievert > Queue: JavaScript > Subject: crash > Broken in: 1.08 > Severity: Normal > Owner: Nobody > Requestors: daphone@legitimatesounding.com > Status: new > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=42653 > > > > on 130th instance of javascript: > > Failed to create runtime at /usr/lib/perl5/JavaScript/Runtime.pm > line 30. > > ubuntu 8.10, installed via apt-get install libjavascript-perl > > quick way to reproduce: > > #!/usr/bin/perl > > use Benchmark; > use JavaScript; > > > my $i = 1; > timethese(150, > { > 'failure' => sub { > print $i . "\n"; > $i++; > my $rt = JavaScript::Runtime->new(); > my $cx = $rt->create_context(); > $cx->eval("var i = 0;"); > } > }); >
From: daphone [...] legitimatesounding.com
Download (untitled) / with headers
text/plain 651b
On Thu Jan 22 03:15:13 2009, claes@versed.se wrote: Show quoted text
> Hi, > > what version of JavaScript.pm does ubuntu package and what version of > SpiderMonkey does it link against? > > your testscript works fine on OS X using SM 1.7 and JavaScript.pm 1.11 >
also works fine on redhat with sm 1.7 and javascript.pm 1.11. ubuntu ships with javascript.pm 1.08, and links against mozlla javascript 1.8.1. see: https://launchpad.net/ubuntu/intrepid/+source/libjavascript-perl/1.08-1 for their patches. see also: https://launchpad.net/ubuntu/intrepid/i386/libmozjs0d/1.8.1.16+nobinonly-0ubuntu1 let me know if i should send this to ubuntu instead. thanks!
From: daphone [...] legitimatesounding.com
Download (untitled) / with headers
text/plain 551b
On Thu Jan 22 10:16:23 2009, jerrysievert wrote: Show quoted text
> On Thu Jan 22 03:15:13 2009, claes@versed.se wrote:
> > Hi, > > > > what version of JavaScript.pm does ubuntu package and what version
> of
> > SpiderMonkey does it link against? > > > > your testscript works fine on OS X using SM 1.7 and JavaScript.pm
> 1.11
> >
> > also works fine on redhat with sm 1.7 and javascript.pm 1.11. > > ubuntu ships with javascript.pm 1.08, and links against mozlla > javascript 1.8.1.
followed up - also fails in javascript.pm 1.11 with mozilla javascript 1.8.1.
Subject: Re: [rt.cpan.org #42653] crash
Date: Fri, 23 Jan 2009 23:37:54 +0100
To: bug-JavaScript [...] rt.cpan.org
From: Claes Jakobsson <claes [...] versed.se>
Download (untitled) / with headers
text/plain 1.3k
On 23 jan 2009, at 15.46, jerry via RT wrote: Show quoted text
> Queue: JavaScript > Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=42653 > > > On Thu Jan 22 10:16:23 2009, jerrysievert wrote:
>> On Thu Jan 22 03:15:13 2009, claes@versed.se wrote:
>>> Hi, >>> >>> what version of JavaScript.pm does ubuntu package and what version
>> of
>>> SpiderMonkey does it link against? >>> >>> your testscript works fine on OS X using SM 1.7 and JavaScript.pm
>> 1.11
>>>
>> >> also works fine on redhat with sm 1.7 and javascript.pm 1.11. >> >> ubuntu ships with javascript.pm 1.08, and links against mozlla >> javascript 1.8.1.
> > > followed up - also fails in javascript.pm 1.11 with mozilla > javascript 1.8.1.
Officially I only support the standalone spidermonkey releases from Mozilla which at the date 1.7 is the latest. 1.8.1 is something they've got with FF probably. The dists Makefile.PL does contain some checks to see if SM has been installed by some package manager but this will go away in some future version as it causes me to much hassle. Could you download, build and test against the official SM release from mozilla (http://ftp.mozilla.org/pub/mozilla.org/js/ js-1.7.0.tar.gz) ? If it still fails using JavaScript.pm 1.11 and SM 1.7 I'll take a look at it otherwise I'll close this as not a bug and you should report it to ubuntu or debian instead. Thanks, Claes
From: daphone [...] legitimatesounding.com
Download (untitled) / with headers
text/plain 316b
On Fri Jan 23 17:38:36 2009, claes@versed.se wrote: Show quoted text
> If it still fails using JavaScript.pm 1.11 and SM 1.7 I'll take a look > at it otherwise I'll close this as not a bug and you should report it > to ubuntu or debian instead.
works with 1.7.1 - go ahead and close and i will report to debian/ubuntu. thanks!
Caused because upstreams SpiderMonkey package provided by distro isn't supported.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.