Skip Menu |
 

This queue is for tickets about the Encode-Detect CPAN distribution.

Report information
The Basics
Id: 42293
Status: new
Priority: 0/
Queue: Encode-Detect

People
Owner: Nobody in particular
Requestors: ANDK [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 1.01
Fixed in: (no value)



Subject: Undeclared dependency on perl version
Download (untitled) / with headers
text/plain 461b
Module::Build supports the declaration of a dependency on a perl version. This enables the toolchain to prevent test reports from older perls. So if you would declare dependency on perl version 5.008 (or higher) we would not see FAIL reports from users of 5.6.2 anymore. So I'd suggest you add requires => { 'Module::Build' => 0, 'ExtUtils::CBuilder' => 0, + 'perl' => "5.008", }, or similar. Thanks,


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.