Skip Menu |
 

This queue is for tickets about the Test-WWW-Declare CPAN distribution.

Report information
The Basics
Id: 41689
Status: new
Priority: 0/
Queue: Test-WWW-Declare

People
Owner: Nobody in particular
Requestors: SREZIC [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in: 0.02
Fixed in: (no value)



Subject: "perl Makefile.PL" reports "unknown version" for Test::Tester dependency
Download (untitled) / with headers
text/plain 827b
When I run Makefile.PL, I get the following output (note the "We have unknown version"): $ /usr/perl5.8.8-MB030/bin/perl Makefile.PL Cannot determine perl version info from lib/Test/WWW/Declare.pm Warning: prerequisite Test::Tester 0.107 not found. We have unknown version. Writing Makefile for Test::WWW::Declare Test::Tester is installed and has the required version: $ /usr/perl5.8.8-MB030/bin/perl -MTest::Tester\ 999999 Test::Tester version 999999 required--this is only version 0.107. An equivalent ExtUtils-MakeMaker-based Makefile behaves correctly. This could be a Module::Install problem, but as the bundled MI is not the latest one, I propose to first upgrade the MI in the Test-WWW-Declare distribution. If the error is still there, then this report should be passed to Module::Install. Regards, Slaven


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.