Skip Menu |
 

This queue is for tickets about the Alien-wxWidgets CPAN distribution.

Report information
The Basics
Id: 41678
Status: open
Worked: 20 min
Priority: 0/
Queue: Alien-wxWidgets

People
Owner: Nobody in particular
Requestors: james2vegas [...] aim.com
Cc: voegelas [...] cpan.org
AdminCc:

Bug Information
Severity: Critical
Broken in:
  • 0.40
  • 0.41
  • 0.42
Fixed in: (no value)

Attachments
patch-inc_My_Build_Any_wx_config_Bakefile_pm



Subject: Can't build on OpenBSD perl 5.10 wxWidgets 2.8.7
Download (untitled) / with headers
text/plain 1.5k
Alien::wxWidgets doesn't build on OpenBSD 4.4-current, i386 with wxWidgets 2.8.7. On ./Build install_wx (or just ./Build) the error message appears malformed. $ uname -a OpenBSD godzilla.bsdhosting.local 4.4 GENERIC#1076 i386 $ perl -v This is perl, v5.10.0 built for i386-openbsd $ perl Build.PL Subroutine version::qv redefined at inc/version.pm line 18. Deleting _build Creating custom builder _build/lib/My/Build/new_from_context_is_broken.pm in _build/lib/My/Build Checking whether your kit is complete... Looks good wxWidgets 2.8.7 seems to be installed in '/usr/local', so it should be safe to answer 'no' to the following question: Do you want to fetch and build wxWidgets from sources? [no ]no $ ./Build install_wx Subroutine version::qv redefined at inc/version.pm line 18. -lwx_base_net at inc/My/Build/Any_wx_config_Bakefile.pm line 25. $ wx-config --cflags -I/usr/local/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/local/include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_IODBC_ -D__WXGTK__ -pthread $ wx-config --libs -L/usr/local/lib -pthread -L/usr/local/lib -L/usr/X11R6/lib -pthread -lwx_gtk2_richtext -lwx_gtk2_aui -lwx_gtk2_xrc -lwx_gtk2_qa -lwx_gtk2_html -lwx_gtk2_dbgrid -lwx_gtk2_adv -lwx_gtk2_core -lwx_base_odbc -lwx_base_xml -lwx_base_net -lwx_base $ wx-config --version 2.8.7 I had to update ExtUtils::CBuilder, since perl 5.10 comes with version 2.1, not 2.4 of that module.
RT-Send-CC: szabgab [...] gmail.com
Download (untitled) / with headers
text/plain 499b
On Sat Dec 13 16:37:52 2008, JWRIGHT wrote: Show quoted text
> Alien::wxWidgets doesn't build on OpenBSD 4.4-current, i386 with > wxWidgets 2.8.7. On ./Build install_wx (or just ./Build) the error > message appears malformed. > > $ uname -a > OpenBSD godzilla.bsdhosting.local 4.4 GENERIC#1076 i386
No updates on this? noone terribly interested in getting WxPerl working on OpenBSD? No Padre either, but then http://padre.perlide.org/search?q=openbsd seems to suggest that it isn't a big deal over there either.
Download (untitled) / with headers
text/plain 946b
On So. 01. Feb. 2009, 06:38:13, JWRIGHT wrote: Show quoted text
> On Sat Dec 13 16:37:52 2008, JWRIGHT wrote:
> > Alien::wxWidgets doesn't build on OpenBSD 4.4-current, i386 with > > wxWidgets 2.8.7. On ./Build install_wx (or just ./Build) the error > > message appears malformed. > > > > $ uname -a > > OpenBSD godzilla.bsdhosting.local 4.4 GENERIC#1076 i386
> > No updates on this? noone terribly interested in getting WxPerl working > on OpenBSD? No Padre either, [...]
I am interested. I've got a local port for Alien::wxWidgets. I'll sent what I've got to the OpenBSD ports list. The problem is that Alien::wxWidgets expects to find a library or symbolic link with the file extension ".so". There's no such file on OpenBSD. There are only versioned files like "libwx_base.so.1.0". I've attached a patch thats shows the places that would need to be changed. It's probably easier to keep these changes in the OpenBSD ports tree though. Regards, Andreas

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 844b
On Sa. 13. Dez. 2008, 16:37:52, JWRIGHT wrote: Show quoted text
> I had to update ExtUtils::CBuilder, since perl 5.10 comes with version > 2.1, not 2.4 of that module.
I think that ExtUtils::CBuilder 2.4 is only required on Windows. It's probably okay to simply patch Build.PL. $OpenBSD$ --- Build.PL.orig Sat Nov 8 00:52:22 2008 +++ Build.PL Mon Jan 5 11:18:10 2009 @@ -26,7 +26,7 @@ my $build = $class->new 'Module::Pluggable' => '2.6', }, build_requires => { 'Module::Build' => '0.28', - 'ExtUtils::CBuilder' => '0.24', + 'ExtUtils::CBuilder' => '0.21', }, configure_requires => { 'Module::Build' => '0.28', },
Download (untitled) / with headers
text/plain 1.3k
On Sun Feb 08 06:13:33 2009, voegelas wrote: Show quoted text
> On So. 01. Feb. 2009, 06:38:13, JWRIGHT wrote:
> > On Sat Dec 13 16:37:52 2008, JWRIGHT wrote:
> > > Alien::wxWidgets doesn't build on OpenBSD 4.4-current, i386 with > > > wxWidgets 2.8.7. On ./Build install_wx (or just ./Build) the error > > > message appears malformed. > > > > > > $ uname -a > > > OpenBSD godzilla.bsdhosting.local 4.4 GENERIC#1076 i386
> > > > No updates on this? noone terribly interested in getting WxPerl working > > on OpenBSD? No Padre either, [...]
Sorry, I missed the ticket... Show quoted text
> I am interested. I've got a local port for Alien::wxWidgets. I'll sent > what I've got to the OpenBSD ports list. > > The problem is that Alien::wxWidgets expects to find a library or > symbolic link with the file extension ".so". There's no such file on > OpenBSD. There are only versioned files like "libwx_base.so.1.0". I've > attached a patch thats shows the places that would need to be changed. > It's probably easier to keep these changes in the OpenBSD ports tree
though. I'd like to have it in Alien::wxWidgets; I just committed a change based on your patch, that makes the changes conditional on $^O eq openbsd; could you try it out? The only thing that worries me is the fixed '.1.0' suffix. Isn't there a way to link to a library without knowing the exact version/revision? Thanks, Mattia


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.